Number keypad not working in Windows 7

my numlock key is on but the digits do not work, i have to use the numbers above the letter keys

*original title - numlock key not working*

 

Question Info


Last updated December 14, 2018 Views 153,237 Applies to:
Answer
None of the tips helped but here is the solution which I found today.

Changing the accessibility options on Windows 7
Control Panel
     l--------> Ease Of Access Center
              i--------> Make the keyboard easier to use
                        i----------> untick 'Turn On Mouse Keys'
This fixed it for me. You can also change the setting for the mouse keys to enable it only when NumLock is off.

300 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

Hi sharonmchugh,

Please see the following troubleshooting steps below thanks to Azam K with Microsoft Support:

Try enabling numeric keypad and check if it helps, here are the steps:

1.      Open On-Screen Keyboard by clicking theStart button, clicking All Programs, clicking Accessories, clicking Ease of Access, and then clickingOn-Screen Keyboard.

2.      ClickOptions, select the Numeric Keypad check box, and then clickOK.

 I would also suggest you to boot the computer in Safe Mode and check if it works properly, here are the steps:

1.     Restart your computer if it is powered on.
2.     Tap the F8 key after your computer initially powers on.
3.     Once you see the Advanced Boot Options menu you can stop tapping.
4.     Use the up/down arrow keys to highlight your selection.
5.     Select Safe Mode and press Enter.
6.     You should see drivers loading, and then please wait.
7.     You should then be at the Welcome Screen.
8.     Logon to your computer using an account with Administrator privileges.
http://windows.microsoft.com/en-US/windows7/Start-your-computer-in-safe-mode

If it is working fine in Safe Mode, then try performing clean boot and check, here is the link:

http://support.microsoft.com/kb/929135

If it is not working in Safe Mode, then try System File Checker and see if it helps, here are the steps:

1.     Click Start, click All Programs, click Accessories, right-click Command Prompt, and select Run as Administrator.
2.     Click Continue or supply Administrator credentials if prompted.
3.     In the Command Prompt window type the following, and press Enter:
sfc /scannow

Here is an article that will give you information on SFC Scan:
http://support.microsoft.com/kb/936212

Hope this helps!


Debra
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think

73 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.