Question

Q: Not able to delete the local printer port on my system

Hi !

I wanted to use my colleague's printer(HP Laserjet P2015d), which does not have a LAN port. But, our PCs are connected to a LAN. Hence, I created a local port on my system to access that printer. I have been using that printer since last 15-20 days. I have Windows 7 Professional 64 bit running on my system whereas my colleague has Windows XP 32-bit. 

I do not know what happened but since yesterday I am not able to print the documents using that printer. After I give the document for print, I check the status and it says "Error-Printing" in the tray icon of the printer. I then removed the printer from control panel and added it back with the same existing local port. It worked once, but the problem has come back again.

I thought of deleting the local port itself and adding it back. 
Then, I tried to delete the local port by selecting that printer-> Printer Server Properties -> Ports tab -> delete port.. But the local port under question is not getting deleted. It throws a message "The requested resource is in use".

Then, I repeated the above procedure after stopping the spool service and restarting it again. But, it just did not work.

I then, changed the printer driver but the problem is not solved yet. Lastly, I asked my colleague to check if the printer is working by giving a print from his system. It worked that way. I then, asked him to disable the sharing of printer and re-enable it. Yet, the problem was not solved.

I request you to give me guidance on how to solve this issue. 

Answer

A:

Go to Start

Control Panel

Devices and Printers

Right click on your printer, left click Printer Properties.

 

Click on ports

 

Tou can uncheck the printer ports there.

 

 

Rick

If you find this helpful, please mark it. Thanks

Dell RockStar

Microsoft MVP April 1, 2012

Did this solve your problem?

Sorry this didn't help.

9 people were helped by this reply



 
Question Info

Views: 23,459 Last updated: July 16, 2018 Applies to: