NO sound when Recording Audio - problems with Windows 7 Ultimate 64-bit

I have been having problems for around a year now with NO sound when Recording Audio with Windows 7 Ultimate 64-bit. I just came across this forum today. It's really weird how the recording with both windows sounds recorder and others has been working perfectly since 1998 or so UNTIL upgrading to win 7. Now each time I try to record it either brings up no recording device found or just fails to record any sound whatsoever. As you'll see below I have enabled  What U Hear so I can use the system sounds recording functions.

I use the sound recording and pdf reader functions because I am legally blind. This is one of the few tools I have been able to use with ease on all my windows systems for many years.

A similar issue started to occur with nvidia graphics cards. AND... I was lead to believe it was an issue with Sony wanting stronger anti piracy measures inbuilt into windows. Am I right in assuming this is what is happening with the sound also now days or is there a solution to this very frustrating problem?

I ran a dxdiag & posted what I believe you requested of another user on the forum, with the same or similar problem.

Help resolving this issue would be greatly appreciated as this has been an issue for quite a while now.

------------------
System Information
------------------
Time of this report: 7/25/2012, 19:06:02
       Machine name: RAIDER
   Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120503-2030)
           Language: English (Regional Setting: English)
System Manufacturer: Gigabyte Technology Co., Ltd.
       System Model: P67A-UD3-B3
               BIOS: Award Modular BIOS v6.00PG
          Processor: Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz (4 CPUs), ~3.6GHz
             Memory: 8192MB RAM
Available OS Memory: 8176MB RAM
          Page File: 2861MB used, 13487MB available
        Windows Dir: C:\Windows
    DirectX Version: DirectX 11
DX Setup Parameters: Not found
   User DPI Setting: Using System DPI
 System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
     DxDiag Version: 6.01.7601.17514 64bit Unicode

------------
DxDiag Notes
------------
      Display Tab 1: No problems found.
        Sound Tab 1: No problems found.
        Sound Tab 2: No problems found.
          Input Tab: No problems found.

 

-------------
Sound Devices
-------------
            Description: SPDIF-Out (Sound Blaster X-Fi Surround 5.1 Pro)
 Default Sound Playback: Yes
 Default Voice Playback: No
            Hardware ID: USB\VID_041E&PID_30DF&REV_0100&MI_00
        Manufacturer ID: 65535
             Product ID: 65535
                   Type: WDM
            Driver Name: ksaud.sys
         Driver Version: 6.00.0001.0460 (English)
      Driver Attributes: Final Retail
            WHQL Logo'd: n/a
          Date and Size: 7/30/2010 11:35:08, 1588608 bytes
            Other Files:
        Driver Provider: Creative Technology Ltd.
         HW Accel Level: Basic
              Cap Flags: 0x0
    Min/Max Sample Rate: 0, 0
Static/Strm HW Mix Bufs: 0, 0
 Static/Strm HW 3D Bufs: 0, 0
              HW Memory: 0
       Voice Management: No
 EAX(tm) 2.0 Listen/Src: No, No
   I3DL2(tm) Listen/Src: No, No
Sensaura(tm) ZoomFX(tm): No

            Description: Speaker (Sound Blaster X-Fi Surround 5.1 Pro)
 Default Sound Playback: No
 Default Voice Playback: Yes
            Hardware ID: USB\VID_041E&PID_30DF&REV_0100&MI_00
        Manufacturer ID: 65535
             Product ID: 65535
                   Type: WDM
            Driver Name: ksaud.sys
         Driver Version: 6.00.0001.0460 (English)
      Driver Attributes: Final Retail
            WHQL Logo'd: n/a
          Date and Size: 7/30/2010 11:35:08, 1588608 bytes
            Other Files:
        Driver Provider: Creative Technology Ltd.
         HW Accel Level: Basic
              Cap Flags: 0x0
    Min/Max Sample Rate: 0, 0
Static/Strm HW Mix Bufs: 0, 0
 Static/Strm HW 3D Bufs: 0, 0
              HW Memory: 0
       Voice Management: No
 EAX(tm) 2.0 Listen/Src: No, No
   I3DL2(tm) Listen/Src: No, No
Sensaura(tm) ZoomFX(tm): No

---------------------
Sound Capture Devices
---------------------
            Description: What U Hear (Sound Blaster X-Fi Surround 5.1 Pro)
  Default Sound Capture: Yes
  Default Voice Capture: No
            Driver Name: ksaud.sys
         Driver Version: 6.00.0001.0460 (English)
      Driver Attributes: Final Retail
          Date and Size: 7/30/2010 11:35:08, 1588608 bytes
              Cap Flags: 0x0
           Format Flags: 0x0

            Description: Microphone (Webcam Pro 9000)
  Default Sound Capture: No
  Default Voice Capture: No
            Driver Name: USBAUDIO.sys
         Driver Version: 6.01.7601.17514 (English)
      Driver Attributes: Final Retail
          Date and Size: 11/21/2010 13:23:47, 109696 bytes
              Cap Flags: 0x0
           Format Flags: 0x0

            Description: Line-In/Mic-In (Sound Blaster X-Fi Surround 5.1 Pro)
  Default Sound Capture: No
  Default Voice Capture: Yes
            Driver Name: ksaud.sys
         Driver Version: 6.00.0001.0460 (English)
      Driver Attributes: Final Retail
          Date and Size: 7/30/2010 11:35:08, 1588608 bytes
              Cap Flags: 0x0
           Format Flags: 0x0

 

 

Answer
Answer

Hi,

 

In Services, verify the Windows Audio service is running and set to automatic.

 

a.   Click Start and type Services and hit Enter.

b.   Make sure these services are set accordingly.

c.   Right click the services and click Properties.

 

According to the DXDiag, there is no default sound capture selected.

 

Description: Speaker (Sound Blaster X-Fi Surround 5.1 Pro)
Default Sound Playback: No
Default Voice Playback: Yes

 

Description: What U Hear (Sound Blaster X-Fi Surround 5.1 Pro)
Default Sound Capture: Yes
Default Voice Capture: No

 

Description: Microphone (Webcam Pro 9000)
Default Sound Capture: No
Default Voice Capture: No

 

Description: Line-In/Mic-In (Sound Blaster X-Fi Surround 5.1 Pro)

Default Sound Capture: No

Default Voice Capture: Yes

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated June 24, 2020 Views 3,216 Applies to: