Question

Q: No Audio, cannot start Windows Audio Endpoint Builder service, RPC server unavailable

I had the audio functioning fine, then I checked off a few services that are safe to set to manual, and now I am having problems with my audio. I went over all the necessary services that need to be started and all of them are set to automatic and running except for the Audio enpoint builder service, windows audio service, and the creative audio service. 

when trying to start windows audio endpoint builder service I get error 1722: the RPC server is unavailable.

I cannot start the windows audio service either. I get a 1068 error message: The dependancy service or group failed to start.
I tried changing the local system account log in info and now I'm getting a different error message: 1079 the account specified for this service is different from the account specified for other services running in the same process.
I tried uninstalling my sound card drivers (creative audigy 2), my onboard sound drivers (AC97) and reinstalling them both, no luck.

I am running Win 7 Ultimate 64

I am also having a problem with my USB keyboard going dead. the backlight stays on, but none of the keys will respond. I have to unplug the USB and plug it back in and wait for it to reinstall. It appears that if I don't use the keyboard for a while it powers down, but the lights stay on. I disabled USB power saving in the power profile and the problem still occurs. My mouse doesn't turn off, so I think it's not related to my power profile. It is a Saitek Gamers keyboard (USB).

Any help would be appreciated.
Thanks,
Alex



eta*

DCOM Server Process Launcher                     started, automatic
Plug and Play                                                     started, automatic
Multimedia Class Scheduler                           started, automatic
Remote Procedure Call (RPC)                          started, automatic
Windows Audio Endpoint Builder                 not started, automatic (error message 1722)

Update#2 I was able to get the right login info to get rid of the 1079 error msg.
I typed in NT AUTHORITY\LocalService and left the password blank.
now I get the same error msg as endpoint builder... RPC server is unavailable.



Edit# 3
I enabled power and everything started to work as normal.
except I still have the keyboard problem.
thanks,

Answer

A:

I am guessing the problem with the Windows Audio Endpoint Builder is that you have disabled the Windows power management on Windows 7.  For some reason, the audio services cannot start if power management is disabled.

I was going to install the APC Power Management software for my UPS and it requires that Windows Power Management be disabled.  I disabled the service and rebooted the system and noticed that the audio services did not start.  Trying to start them by hand gave the errors you mentioned.  When I started the power management service, I was able to start the audio services.

Microsoft does not mark these as dependent services, but there is some relation.  I know in Windows 7 that they were saying it optimized power utilization for audio and I am guessing that the audio services are looking at the power management to see what type of profile is in use.  Since power management is not running, this is not available and the audio services terminate.  Again, this is just a guess and I cannot find any definitive answers about this.

Did this solve your problem?

Sorry this didn't help.

143 people were helped by this reply



 
Question Info

Views: 76,412 Last updated: June 20, 2018 Applies to: