New Win7 Pro will not recognize USB attached drive

I have just built a new system.  I have a USB attached hard disk and windows does not see it when I attach it. It is not shown in device or disk manager. Worked fine on two XP systems.  I need the information on the drive. Saw a semi related post from my search and deactivated the USB function allowing the machine to turn off USB power to save power. The external drive is self powered.
 

Question Info


Last updated September 8, 2019 Views 7,812 Applies to:
Answer
Answer

Your USB hard drive needs to:

1) Be shown in Device Management

2) Accessed in Disk Management and either formated or have a drive letter assigned to it

 

It should also be note that Windows 7 by default will not show "Empty" drives besides the floppy, CD, DVD and internal hard drives.  This is a setting to "deactivate."

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Hi alternety599,

 

a. What’s the make and model of the external hard drive?

 

You may delete the USB Upper Filter & Lower Filter entry and check if that helps.


Before we go any further, please first backup the Registry.


Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

 

 

How to back up and restore the registry in Windows

http://support.microsoft.com/kb/322756/

 

1.   Click Start, type regedit in the Start search bar and press Enter to open Registry Editor.

2. Locate the UpperFilters value under the following key in the registry:


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}

3. On the Edit menu, click Delete, and then click OK.
4. Locate the LowerFilters value under the same key in the registry:


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}

5. On the Edit menu, click Delete, and then click OK.
6. Quit Registry Editor and restart the computer.

 

Hope this helps.


Gokul - Microsoft Support

[If this post was helpful, please click the "Vote as Helpful" (green triangle) button. If it helps in resolving your issue, click "Propose As Answer" or "Mark as Answer" button. By proposing/marking a post as Answered, or Helpful you help others find the answer faster.]

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.