Question
15223 views

Logitech Gamepad F310 error Failed to Install Drivers

AriRockefeller asked on

Original title L-: Logitech Gamepad F310 Won't Work Because Windows Failed to Install Drivers

 

Just purchased a Logitech Gamepad F310 controller. I can't actually use it with anything because I get the "Failed to Install Drivers" message. Tinkering around in the Device Manager does nothing. Two 45-minute calls to Logitech and a 20-minute call to Microsoft also did nothing (the latter of the three due to me not wanting to pay $99 to buy a warranty and fix the problem; for perspective's sake, the controller retailed for $25, a.k.a. not even remotely worth it).

So what do I do to force my computer to install the drivers and use the controller properly?

70 people had this question

Abuse history


Most Helpful Reply
CheongZun Jie replied on

Hi all. I have a similar problem with my Logitech Gamepad F310. As i try to connect the controller to the computer via. usb port, it states that the usb device is not recognized. I tried connecting it to other computer but it displays the same problem. I tried method 2 but it just states that it is not functioning properly as skipped the step. i tried method 3 and there is no detection. Method 4 also does not work. Please help!
13 people found this helpful

Abuse history


progress