Lifecam Studio stopped working after firmware upgrade?!?

Hi All.

 

I bought a new LifecamStudio 2 days ago. I installed the camera, following the instructions of course. In the end of the installation, I could se my self in the Lifecam software window, so far no problems, the camera worked. Suddenly a popup message appeared, telling me that the firmware of the camera needed to be upgraded, so I pressed OK. The firmware upgrade started but was shortly aborted with an errormessage, saying the upgrade was not succesfull. I tryed to reinstall  the firmware, but now it tells me hat I already have the most recent firmware installed. So the nproblem is now that, when I instert my camera into the USB port windows finds the camera, but as soon as I start any program the uses the camera it goes from a Lifecam Icon (in the hardware manager that is) to a unknown unit. The Lifecam studio software tells me that no camera is installed. I have installed the camera on other computers without any luck. 

/Stefan

 

Question Info


Last updated August 26, 2019 Views 8,351 Applies to:
Answer
Answer
Fixed it :)
In device manager underneath imaging devices I saw "Webcam" -- before the botched fw update it said "Microsoft LifeCam Studio" and had a diff driver.  I rolled back the driver (or if that doesn't work you can force it to use the one inside program files \ lifecam) then re-installed lifecam -- my cam now works.  Now -- what's the deal with this update utility and why's it changing what driver the camera uses?

17 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.