I can not install any drivers at all!

This is not the first time I have experienced this issue with Windows 7.  There seems to be some issue with maybe the order that I am doing things in... But this problem is beyond unacceptable. 

 

I can not install any drivers whatsoever.  Basically what is happening is, when I plug a device in, windows will act like it is searching for the driver and then it will come up with a notification that it failed to install it giving no reason whatsoever.  If I go to the device manager and manually install the driver it will say "Windows found drivers for your device but encountered an error when trying to install them.

To summarize what I have done to this machine:

Performed all windows updates

Turned off windows update

Turned off windows firewall

Turned off windows defender

Adjusted system settings for "Adjust for best performance"

Checked the hardware settings for automatic driver installation to ensure that they are on.

I am running windows 7 x64

I am truly confused as to why this is happening.  Could someone please help?

 

 

 

Question Info


Last updated March 13, 2018 Views 99 Applies to:

What is the make/model of PC?

In windows update, settings turn on important updates ONLY

Turn the firewall back on

What other anti virus program are you using? McAffee/Norton or?

In Device Manager are there any yellow warnings?

What hw devices are you pluging in?

Is this a preinstalled Win7 or do you have an actual win7 dvd?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is an intel motherboard with an i7 860.

I can't turn on automatic updates due to the possibility of interference of the exhibit in the future.

I do not want the firewall on as this is on an isolated network.  This pc is being used for interactive museum exhibits and the firewall could possibly interfere with application development ( I know.. but the developers demand it off via contract...)

 

I am not using any antivirus software.

There are only yellow warnings in DevMgmt when I plug in a device that is unrecognized...  Funny thing, the usb ports that the mouse and keyboard were origianlly hooked up to work, but if I move usb ports around the drivers will not install...

I am plugging in USB keyboard and USB mouse.  Strangely, thumb drives and portable HDD's install fine now...

 

I have the win7 dvd that I purchased as an oem system builder license.

 

Thanks for any help.  It is much appreciated!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Manually install the drivers from the manufacturers website?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Oh yeah... Even if I turn on all settings that were turned off, it does not resolve the issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Tried, but to no avail...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

purchased generic external dvd/cd burner reader, advertisement stated it was windows 7 compatible, but get error message when installing drivers, and have 2 yellow caution flags  When I trouble shoot it says all drivers are current and working, but device is not working???

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.