How do you change the communication port settings in Windows 7?

I would like to change the communication port settings in windows 7 so that my p.c will be able to communicate with an equipment. i have already installed the equipment software but apparently need to change the comm port settings to comm port 1-9. I have checked the device manager but could not find the communication port. Please help.
 

Question Info


Last updated April 16, 2019 Views 18,781 Applies to:

Hi,

1.       Which communication equipment are you referring to?

2.       Why do you want to change the communication port settings?

3.       Do you get any error code or error message?

 

I would suggest you to check in Device Manager for the Com port in use and try to change the settings, so that you can use it.

COM PORT IN USE: If the installation is not completely successful, the COM port assigned with that installation may continue to be identified as 'in use' by Windows, even though it really isn't in use.

You can reclaim these 'used' COM ports that really are not in use:

a.       Open the Device Manager by clicking on the button from 
Control Panel->System->Hardware tab->Device manager->Expand the Ports->listing and double-click your COMMUNICATIONS PORT (normally COM1

b.      Click on the Port Settings tab, and then click the Advanced button.

c.       Select the COM Port Number dropdown and change it a COM port that shows 'In Use' that really isn't in use.

d.      Click OK, and continue past warning about using a used port.

e.      Repeat for each false in use port.

f.        Repeat and change the port back to original (COM1) setting and check if the issue is fixed.

 

Hope this information is useful.

Basith M
- Forum Moderator (Multiple Forums)

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for your reply but unfortunately am stuck at (a). In my Device manager i don't see the ports list to expand therefore no communication ports. I tried expanding the lists just in case it is hidden but unfortunately there is no communication ports to be seen.

41 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.