How Do I change from IDE to AHCI for my hard drives in windows 7?

Made the change in BIOS but Windows 7 just gives me the blue screen at startup.   Tried to boot from my Windows disk and run startup repairs.  No success.   Windows could not make the repair.  Had to return BIOS to IDE mode for the drives.

I under5stand that I will need AHCI in order to add any solid state drive.

Hardware is as follows:

Gigabyte GA-890GPA-UD3H motherboard, AMD Phenom II 965 processor, 6 Gigs DDR3 memory. Western Digital 1TB SATA3 hard drive, Baracuda  1TB SATA2 hard drive.

   Appreciate any suggestions.

 

 

Question Info


Last updated October 22, 2018 Views 193,943 Applies to:
Answer

See http://support.microsoft.com/kb/922976.

The Msahci driver in Windows 7 is disabled if the original install was made with the BIOS set to native IDE. The Msahci driver must be enabled before you change the SATA/RAID mode of the boot drive.

23 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.