ERROR: Unable to start Bluetooth stack service.

I have a Lenovo X201 running Windows 7 Professional SP1 and every time I boot up I get a BTTray Error Message.  Action Center messages recently sugetsed I Needed to update Bluetooth driver and provided a link to Broadcom; clicked on link, ran update tool and got a message from Broadcom I Needed to contact vendor for update; contacted Lenovo who said it is a Microsoft Windows problem and I need to contact Microsoft.  Searched error message and have tried several steps and none work.
 

Question Info


Last updated February 26, 2019 Views 2,015 Applies to:
Answer
Answer

Albeit Fixit was Windows Vista solution, these documents still hold true in Windows 7. Try the manual instructions.  Be sure to backup the registry before making any changes.

 

322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

To fix this problem yourself, follow these steps:

  1. Click
    Collapse this imageExpand this image
    , type regedit in the Start Search box, and then press ENTER.
  2. Locate and then right-click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\ControlPanel\NameSpace\{28803F59-3A75-4058-995F-4EE5503B023C}
  3. Click Delete.

    Note If you are prompted to confirm the key deletion, click Yes.
  4. On the File menu, click Exit.

 

 

Is Norton still installed and used?

 

You might try disabling both AV and Firewall before installing.

 

Code 28

The drivers for this device are not installed. (Code 28)

Recommended resolution

Install the driver

You may be prompted to provide the path of the driver. Windows may have the driver built-in. If you are asked for the driver and you do not have it, you can try to download the latest driver from the hardware vendor’s Web site.

 

First perform a scan of system files

 

Start > Type CMD

Right click on CMD and select Run As Administrator

Type sfc /scannow

Press Enter

Note:  There is a space between sfc and /scannow

How to use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7

http://support.microsoft.com/kb/929833

 

You may be asked for your installation DVD if files have corrupted.

 

Hardware devices are not working or are not detected in Windows   

http://support.microsoft.com/mats/hardware_device_problems/

 

Have you tried to put the phone in DFU mode and then restore?

http://modmyi.com/forums/general-iphone-chat/681467-iphone-error-28-a.html


Pat
As a responsible member of the community, please mark the reply that has resolved your issue. Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.