disable bluetooth Secure Simple Pairing (ssp)

Hi,

I have an old Bluetooth headset (Z-W88), which cannot be paired in Windows 7 - it shows a code and it asks me to compare it to the one on the headset. No matter how I respond to the question (yes or no), the pairing fails.
I figured it out that my headset does not implement / miss-implement other authentication than PIN authentication.
In Windows XP, which does not provide support for Bluetooth 2.1+EDR and Secure Simple Pairing, I was able to use the headset without any problem.

In Ubuntu 12.04, initially I had the same authentication problem. But after I executed the command "hciconfig hci0 sspmode 0", I was able to connect the headset.
My question is how can I do the same thing in Windows? How can I disable the Secure Simple Pairing Mode? I couldn't find any option in the Bluetooth settings. I searched in the registry, but still nothing. I wrote a C++ program in which, in the Bluetooth authentication callback, I set/force the authMethod member of the BLUETOOTH_AUTHENTICATE_RESPONSE structure to BLUETOOTH_AUTHENTICATION_METHOD_LEGACY and pass it to BluetoothSendAuthenticationResponseEx function. Still nothing.

Thanks for your help.

Answer
Answer

Hi Marius,

The issue you have posted would be better suited in the MSDN Forums. I would recommend posting your query in the link below.
http://social.msdn.microsoft.com/Forums/windows/en-US/home?forum=winforms

If you need any further assistance with Windows Operating System, please post your query on Microsoft Community Forums and we’ll be glad to assist you with it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated June 15, 2020 Views 1,031 Applies to: