Disable automatic switch to plugged in audio device?

Hey there.
I am routing my audio via the HDMI connected sound system.
I am using a Tritton Headset which grabs the audio from the sound system for 5.1 sound.
In addition, the Headset is plugged in via USB to enable voice chat during games.

Now my problem: When i switch on the Headset, Windows detects a new audio device and switches the default audio away from my sound system to the USB.
How can i disable this behaviour? The default audio device should be HDMI whatever happens to the Hardware.

Thanks! :)

Hi Lucleonhart,

Thank you for posting your question in Microsoft Community.

From the issue description, you are not able to set HDMI as default device. I will be glad to assist you on this issue.

1. Who is the manufacturer of your sound card?

2. Have you installed the latest drivers for the sound card from the manufacturer’s website?


Follow the steps mentioned below.

a. Right click on the sound icon that is present in the notification area (bottom right corner of the desktop screen)

b. Click on Play back devices and in Play back tab, if you can see speakers then right click on it and click enable and then set it to default.

c. If you cannot see the speaker icon in the sound window then, right click on the empty space in the play back window and make sure that the ‘show disabled devices’ is checked.

d. Then follow the step ‘b’ to set the speakers are the default device and enable it.

Check whether you are able to hear sound.


For further reference check the article mentioned below.


Tips for fixing common sound problems

http://windows.microsoft.com/en-US/windows7/Tips-for-fixing-common-sound-problems



If not, I would suggest you to install the latest drivers from the manufacturer’s website and install it on the system.

Update a driver for hardware that isn't working properly

http://windows.microsoft.com/en-us/windows7/Update-a-driver-for-hardware-that-isnt-working-properly


Do get back to us and let us know the status of the issue, I will be glad to help you further. We, at Microsoft strive towards excellence.


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

go to control panel , see the sound manager icon there , choose , click properties , you two or more devices appear , set your preference as  output
I am a regular CONTRIBUTOR on docs.micrsosoft.com Asus Laptop R542UQ-DM153-Intel_i5-7200u_Nvidia_940mx_2GBvram-16GBram-2TBHDD_2TBHDD_250GB_M.2SSD_Windows10_Enter_2004_64bit_19042.572

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi and thanks for the answers.
Sadly, you two missed the point of my problem.

So i AM able to set the HDMI output as my default sound output, no problem.
Let me describe you the steps that lead to my audio problem:

1. Switch on PC and TV
2. Default Sound output is HDMI, i casn hear the sound through my TV, perfect!
3. I plug in my USB Headset.
4. Windows reconfigures the new USB sound device as the default output. (THIS is what I want to disable)
5. I must open the sound configuration and manually reset the HDMI output as my default sound device.
6. I plug off my USB sound device, HDMI stays the default device (all good).
7. I re-insert the USB sound device and AGAIN it is set as the default device and i can hear nothing...

I hope it is a bit clearer now. 
I need an option like "Do not switch to newly attached sound devices" or "ALWAYS use this putput device"

---

Another hint: I cannot disable the USB device as sound output, because i need it as my default communication device (it is a headset after all).

Thanks again!

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I actually have this issue as well I would like to stop the automatic process of selecting my audio devices.. I want to choose my devices not let the computer choose for me..

Their has got to be a way to disable this annoying feature of automatically selecting the audio output..

I have windows 10 pro please fix this..

I use my computer for live recording and playback.

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello, i do have this problem too. 

For clarrification  here the description from the theadstarter at the end of this post:

1. Switch on PC and TV
2. Default Sound output is HDMI, i casn hear the sound through my TV, perfect!
3. I plug in my USB Headset.
4. Windows reconfigures the new USB sound device as the default output. (THIS is what I want to disable)
5. I must open the sound configuration and manually reset the HDMI output as my default sound device.
6. I plug off my USB sound device, HDMI stays the default device (all good).
7. I re-insert the USB sound device and AGAIN it is set as the default device and i can hear nothing...

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same issue, and I can say it is infuriating. 

In my case, rebooting my machine will often times make one of my monitors the default playback device, even though previously I had set this device to 'disabled' in playback devices. 

I have essentially trained myself, every time I reboot, or every time I have to turn the monitors off and on again, to check playback settings and make sure the proper outputs are being used. 

Extremely annoying. Please Microsoft, wtf. 

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This also happens every time I install new drivers for any video card capable of playing sound through HDMI or DisplayPort (i.e. the monitors' speakers).

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated October 28, 2020 Views 12,734 Applies to: