CD/DVD does not auto play when inserted into drive

original title: auto play

hi can anybody tell me how to get my dvd/cd drive to start automaticlly? thanks in advance i am running win7 and just installed new drive.

 

Question Info


Last updated April 17, 2019 Views 12,433 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi trythisthen,

Have they just stopped working automatically or have they always not worked?

If they have just stopped working then the chances are that the autoplay/autorun option has been disabled in the registry - Windows occasionally does this for some unkonw reason.

If this is the case take a look at this link from my website: http://vistasupport.mvps.org/autorun_autoplay_don't_work_when_cddvd_is_inserted.htm


This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, it's employees, or other MVPs.

John Barnett MVP: Windows XP Associate Expert: Windows Desktop Experience: www.winuser.co.uk | vistasupport.mvps.org |xphelpandsupport.mvps.org |www.silversurfer-guide.com

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi JOHN I'M AFRAID THAT I HAD NO LUCK WITH WHAT YOU SUGESTED ACCORDING TO THE REGISTERY IT IS ENABLED SO I AM STILL HAVING TO START WINDOWS MUSIC PLAYER AND CLICK ON TO DRIVE D TO PLAY THE DISC AFTER LOADING IT INTO DRIVE.

tHANKS FOR TRYING TO HELP GEORGE.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Mohanad

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi George,

Click Start button and then click the Control panel option. In Control Panel, click the Autoplay icon. In the autoplay window click the 'down arrow' in the box to the right of the Audio CD option. From the list select 'play audio CD's with Windows Media Player' Finally click the Save button art the bottom of the AutoPlay window.


This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, it's employees, or other MVPs.

John Barnett MVP: Windows XP Associate Expert: Windows Desktop Experience: www.winuser.co.uk | vistasupport.mvps.org |xphelpandsupport.mvps.org |www.silversurfer-guide.com

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi have followed your link to the letter but have had no luck thanks for trying.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No John fraid still not working getting frustrated abit now though i have a lot of pacience and will not give up in a hurry.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi trythisthen,

Is this an internal drive (some laptops use external disc drives)?

Is this a disc you've burned or a store bought media disc?

How long are you waiting for the Autoplay to start? It could take several seconds.

What is the file type on the disc (mp3, wma, cda, etc)?


Chris
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi this is an internal drive for a desk top,

will not play shop bought discs or ones that i have burned myself,

i wait till the indicator light on the drive stops then for another 10 secs,

the disc types are mp3 and any other that you buy from shop.

will play or burn when entered into windows player manuelly via drive

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

the  value of Autoplay  is 1 but the "Autoplayisalwaysdisable". :( please  help me out....mail me *** Email address is removed for privacy ***..thank you

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have this same problem with Auto Play not working when I insert a CD or DVD.
I have followed all the advice for finding the problem in the registry.
The Auto run value is 1 in HKEY_LOCAL_MACHINE\system\currentcontrolset\services\CD Rom

I then went to HKEY_CURRENT_USER\software\microsoft\windows\currentVersion\policies\explorer , however even though I used the registry search option I could not locate the entry "NoDriveTypeAutoRun" after searching  I get the message "search complete" but it does not locate that particular entry.
I did follow another set of advice on the help forums, and this brought me to a dialog box with a command prompt in it. After typing the requiste command in I got the message that the command could not be carried out as the "AutoRun was disabled"

I am at a loss to find where this erroneous registry entry is. I hope you can help.

I did have Roxio Creator DE on th PC, but before I attempted all the above I uninstalled it via the control panel.

I'm running windows 7 Ultimate on a Dell desktop

Many thanks if you can help solve this problem

John Watson

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.