Question

Q: Canon MP Navigator Stopped working with scanner. Worked under Vista, not Win 7. This thread is locked from future replies

Canon scanner Lide 200 worked fine in Vista 64.  I upgraded to Win 7 64 and the interface software stopped working - "MP Navigator EX has stopped working".  It is a BEX error, Fault module MSONSEXT.DLL_unloaded.  I uninstalled, downloaded the newest and reinstalled, same problem.  Canon had me create a new profile, program works in that profile.  Canon says it is a rights or OS issue. 

The scanner works with other software.  MP Navigator is a resident program to do copies or copy and email, etc.

Here is the detail from the windows error

Problem Event Name:    BEX
  Application Name:    mpnex20.exe
  Application Version:    2.0.3.0
  Application Timestamp:    488d25b8
  Fault Module Name:    MSONSEXT.DLL_unloaded
  Fault Module Version:    0.0.0.0
  Fault Module Timestamp:    43306199
  Exception Offset:    49143a3b
  Exception Code:    c0000005
  Exception Data:    00000008
  OS Version:    6.1.7600.2.0.0.768.3
  Locale ID:    1033
  Additional Information 1:    0f31
  Additional Information 2:    0f3137665bbf0bb676c8a16f3fa76e52
  Additional Information 3:    fff8
  Additional Information 4:    fff84cbc2f915b8472e90c61e476efef

Answer

A:

I have had the same problem with Win 7 64. I spoke to Canon Tech Support and after an hour during which we tested various things I was told the the problem was with Windows and I should contact Microsoft. I tried creating a new profile which fixed the problem for about a week, then it came back again! The issue may be associated with Windows Update but I am not sure. On this last go around I created a new profile, then copied in the folders and files from the corrupted profile one at a time to see when the problem would start again. After carefully copying files, backing up, testing Mp Navigator, and if necessary restoring the last good setup I discoved that the following file was causing the problem:

C:\Users\<user name>\App Data\Roaming\Microsoft\Windows\Network Shortcuts\My Web Sites on MSN

Note: This file was not present in my new profile. Also, the icon has the shortcut marker on it, but explorer says it is a folder. There is no file extension.

I eventually copied ALL of the other data from the bad profile to the new one and MP Navigator still worked! I then deleted the offending file from the bad profile and MP Navigator started working there too!

I then reconfigured all of my software and started IE etc. for the first time while watching the Network Shortcuts folder. The offending file has not reappeared yet. I made a shortcut to this location so I can keep an eye on it to see when it appears again.

Hopefully someone at CANON or Microsoft will fix this "corrupted" profile issue.


Sincerely,

David Witteried

Did this solve your problem?

Sorry this didn't help.

16 people were helped by this reply

Answer

A:

Hey GregDaro,

Thanks for posting in Microsoft answers!

The issue could be related to a corrupt user profile, since you’ve stated in your post that the program works fine in the other profile you’ve created.

Refer the link below for more details on fixing a corrupt user profile:

Fix a corrupted user profile
http://windows.microsoft.com/en-US/Windows7/Fix-a-corrupted-user-profile


Hope this helps!
Gokul – Microsoft Support.

Did this solve your problem?

Sorry this didn't help.



 
Question Info

Views: 141488 Last updated: February 6, 2018 Applies to: