Printer sharing stuck w/o drivers

Hey all.

I've got W7 x86 installed with a USB Epson RX620 working great.  The PC I'm trying to share the printer with is Vista Ultimate x64.  When I search the network for the printer, find it, select it, I get a message about "the server does not have the right driver". 

So, I came here and I followed these really great, detailed steps to set up sharing to other PCs on my home network:
http://social.answers.microsoft.com/Forums/en-US/GettingReadyforWindows7/thread/88b53ce6-b613-4e05-8da3-00e40c2d612b

When I get to the part in these instructions that allows you to add additional drivers, the x86 are already present, the x64 are not.  As expected.  When I select to add the x64 drivers (presumably the ones that the Vista x64 machine is requesting), I get prompted to select the location of the the driver.  Hence the problem.  Everything I can find on Epson's site and MS sites say that "vista drivers get automatically downloaded and installed".

I can't find anywhere the driver to just download and then use.

Can anyone suggest a work around for this?  I'm stuck :(

Thanks for your time

 

Question Info


Last updated April 5, 2018 Views 811 Applies to:
Answer

Hello chrisneal,

Thank you for visiting the Microsoft Windows Vista Community site. The issue you posted is a post Windows 7 installation issue and would be better suited in the TechNet community. Please visit the link below to find a community that will offer the support you request.

Windows Client TechCenter > Windows 7 Forums

Thanks,

Jack


Jack
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.
Jack
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us k

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.