Can't use dual monitor with Windows 7 64-bit and GeForce 9800GT

This has been an unsolved issue for me since I installed Windows 7 last year.  I've read numerous articles, none of which have solved the problem.

 

I have Windows 7 64-bit installed on a Core 2 Duo 2.2 GHz, 2GB RAM, and using a GeForce 9800GT video card.

PROBLEM:  As soon as I connect a second monitor (DVI to HDMI or DVI to VGA) the original monitor goes black and there is no display on the 2nd, newly connected, display.  If I disconnect the second display, the 1st monitor remains black until restart.  Note:  I had both connected during the original install and the install could not finish as the monitors went blank, so I had to reinstall with only 1 monitor connected.

 

I have the latest Nvidia drivers installed and all critial updates installed.  How can this be solved?  Thanks.

 

Question Info


Last updated October 3, 2018 Views 2,701 Applies to:
Answer

i'm using a dvi to vga adapter, but that's not the issue because I prodominately use that display and it works fine.

 

I should mention, this is a compatibility issue with Windows 7 x64, and not a hardware issue, because the same machine has no issues in Vista (also installed on the machine with the same hardware configuration).

 

I actually first noticed this problem during my first Windows 7 installation attempt when i had both displays plugged in during install and the install went blank just over halfway and could not continue.  I had to reinstall with the second display not plugged.

 

Thanks..

You want to hope that it is not a compatibility issue, because that could leave you SOL for a solution. Assuming that anyone is even working on a solution. I had some issues crop up after upgrading from Vista that never existed when running the Windows 7 RC on the same computer. The cause of an issue isn't neccesarily in a straight line between Win7 and the problem device. The only things I can think of now are the standard, tedious, software/driver troubleshooting techniques.    Starting with 'do the displays exhibit the same behaviour when a simple SVGA driver is all that is installed?"

Some similarly difficult device issues have been resolved by reinstalling Windows 7.  I'd try updating the motherboard chipset drivers before going that far, followed by if possible, a clean install of Win7 on a separate partition to see if the same problem occurs.

 

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.