Failed eHome IR (USBCIR) Install on USB Card Reader Insert

I have a reasonably clean and fresh W7 Pro 32 install on a Fujitsu Lifebook T Series Tablet.  I rcently bought an Epraizer Card Reader to enable me to import photos from a CF.

On installing it for the first time, the driver installs failed.  The driver it failed on was the eHome Infrared Receiver (USBCIR).  To the best of my knowledge, the device does not contain an IR device of any sort.

I inserted the same device in an XP machine and it worked fine.  Have I:

(a) wasted my money,
(b) encountered a known problem with a simple fix (do tell), or
(c) tripped over something nasty I don't want to know about (see a)?

Any comments and information would be appreciated.

Nick
 

Question Info


Last updated June 14, 2018 Views 6,831 Applies to:
Answer

Hi NicholasMcG,

I would suggest that you check if this device is compatible with Windows 7 or not. I did search for the device compatibility on Windows 7 compatibility center and found no information about this device which confirms that the device may or may not be compatible with Windows 7.

Windows 7 compatibility center link: http://www.microsoft.com/windows/compatibility/windows-7/en-us/default.aspx

As per the research from the manufacturer’s website, this device is compatible with Windows XP and Windows Vista.
Refer the link: http://www.epraizer.com/p_cr_sc900.htm

The software might fail to install only if the device is not compatible with Windows 7. As a workaround you may try installing the software in Windows XP compatibility mode and check the result.

To change compatibility settings manually for a program, right-click the setup icon, click Properties, and then click the Compatibility tab.

Refer the link to install in compatibility mode: Make older programs run in this version of Windows: http://windows.microsoft.com/en-us/windows7/Make-older-programs-run-in-this-version-of-Windows

Swathi B  - Microsoft Support.
Visit our Microsoft Answers Feedback Forum and let us know what you think.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Try this link worked for me epraizer 62 in 1 reader running windows 7
http://blog.aheil.de/2009/12/12/FixingWrongUSBDevicesInWindows7.aspx

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.