TP-Link TL-WN951N 64Bit Issue

I have just purchased the TP-Link WN951N wireless PCI card to upgrade from my old adapter and have encountered a problem when trying to install the driver. I have been to the TP-Link website and tried all of the availbe drivers that they have listed for Windows 7, I have also tried installing an Atheros driver as when I have been searching through Google I found that it uses an Atheros chipset.

The drivers that I have tried appear to install although I get a warning when first installing that it might not be compatible and the driver says that it is installed and working but I cannot see any wireless networks. When I click on the diagnose button it goes through it's process and then tells me that there is a driver problem still.

In the device manager it says that the device is working properly and in the Network Connections section if i double click on the icon it reports that it is connected at 412.3Gbps which is confusing in itself but when i click on the details tab to see the state of the connection both of the property and value tabs are blank

Also I have had no error codes that may help in the diagnosis so sorry about that :-(

I hope this is enough information for someone to at least suggest what may be the problem

 

Question Info


Last updated October 16, 2018 Views 12,657 Applies to:
Answer

Sorted it, turns out Zone Alarm was causing the whole problem. Should have checked that earlier >.<

Thanks for the speedy response anyway Mike

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.