Sidewinder X3 freezes up randomly

My sidewinder X3 is freezing up for several minutes at a time. It doesn't seem to affect any other processes. My cursor just stops moving and the on-the-fly sensitivity changer won't work either. After a while the mouse starts working again by itself. Re-plugging the mouse has no effect. I have another optical USB mouse that works flawlessly in the same ports as the sidewinder. The mouse is brand new and it has been doing this ever since I purchased it. Im running windows 7 64-bit. Has anyone else encountered the same problem? What solved it?
 

Question Info


Last updated May 14, 2018 Views 895 Applies to:
Answer
It is sounding like your X3 could be defective. Try a clean reinstall of the updated mouse drivers (uninstall the existing driver, reboot, then reinstall the new driver.) If it still doesn't work and you're within your retailers time period for product returns I suggest you get the mouse replaced.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.