RollerCoaster Tycoon - Cannot Load/Save Games

I have had RollerCoaster Tycoon for several years now and it always worked fine.  So I went ahead and installed it on my laptop and it worked for quite a few months until one day I couldn't load my saved games, and any new game I started I couldn't save.
When I try to click the load/save game button, nothing happens.  I click it quite a few times and still nothing happens.  All it does when I click it is stop for a second as though it's going to load it, then just returns back to what it was doing before.
I tried un-installing and re-installing (using THIS method so I don't loose my progress) to see if it helped but it didn't help (I also lost my progress after I did the step where you put the time on your computer back to the original time, but I'm alright with starting again).

Also, when I exit the game a little window pops up titled "Error Trapper" and in the window there is a picture of a red "x" and beside it it says:

Exception Raised - Access Violation
Error Location: Unknown


(If you need me to post a picture of the window, then just tell me)

I have been searching for half the day for a solution but haven't found one, so if anyone has any idea on how to fix this I will be grateful.

Thanks, KingGnome

UPDATE: A patch from the answer can be found here:
http://www.rctstationarchive.com/downloads/patches.shtml

When the page loads, select the patch of your language that the game is in and run it (If you live in Australia, like me, I just used the US version as the UK one didn't work).

 

Question Info


Last updated October 29, 2018 Views 7,630 Applies to:
Answer
As far as I know, there's a patch available for RCT1. Have you tried obtaining this and installing it yet?

Regards,

Patrick
Debugger/Reverse Engineer.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.