Flight Simulator X has encountered a fatal error. blah blah blah

So, I have been having this problem for about 3-4 days now. Game starts, after a few minutes it just crashes. Ive read these other forums and tried the "solutions" that they were given. No joy. I did the compatibility for Vista SP1 mode, did not work. Made sure all my drivers are up to date, did not work. Made sure Direct X and C++ are up to date, did not work. It's really getting annoying that a Microsoft made game, is not working with a BRAND NEW Microsoft operation system.

Things that trigger a game crash:
1. Changing views in game.
2. Opening ATC window.
3. Nothing, it just crashes.

So, I upgraded my computer from old hardware and WinXPPro32bit sp3 to newer, faster hardware and Win7Pro 64bit.
Computer specs as follows:
 
CPU - Intel Core i5-750 2.66GHz
Mobo - ASRock P55 Extreme
RAM - 4GB Corsair XMS3 DDR3-1600
Video - nVidia GTX 260
OS - Microsoft Windows 7 Professional 64bit

Like I said, I checked my drivers, DirectX, C++, and tried running in Vista SP1 mode. And none of it works. I don't want to sound like a jerk, but its just getting really annoying and frustrating when they don't work, especially if they are both Microsoft products... Any help would be nice, and again, Ive read similar post on this site from people with the same problem, and tried what they tried, and still no luck for me, or them. Any type of help would be greatly appreciated, and thank you in advance.

- Calvin
 

Question Info


Last updated April 2, 2019 Views 42,888 Applies to:
Answer
Answer
Ccraig38,
      Here is a link that for the DirectX 9.  Give this a try and post back with results.
Mike

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.