Question

Q: D3drm.dll is missing while playing old games

Original Title: D3drm.dll is missing?

Trying to play somewhat older games (one 2005 the other 2003) off of CD-ROM, but won't work with message saying d3drm.dll is missing for both. Tried downloading directX update from microsoft, but message still appears. Tried the Fix It (Mats_Run.devices and Mats_Run.dvd) Currently downloading the DXSDK_Jun10.exe file trying to fix it.  Help?

Answer

A:

I am also trying to get TopoUSA4 to run in Win7, placing the d3drm.dll in the executable's folder, the Windows folder or several other likely spots has not helped.

 

///////////////UPDATE/////////////////////

Placing the missing dll in the OS root and with the TopoUSA4's executable actually worked after a reboot. If you obtain this file (d3drm.dll) from a googled source that you don't know, scan it with your antivirus or other protection software (e.g. Malwarebytes). I was lucky.

As of this writing (November 2012) you can get a zipped version of the DLL here: http://www.dll-files.com/d3drm.zip?0WHfUEaKiU Note that you do not need the repair program that installs it, just read the instructions for using the zip file under the heading "how to install d3drm.dll" on this page: http://www.dll-files.com/dllindex/dll-files.shtml?d3drm. Again, as of this writing, Avira and Malwarebytes report that the zip is clean.

Did this resolve your issue?

Sorry this didn't help.

40 people were helped by this reply



 
Question Info

Views: 93746 Last updated: November 20, 2017 Applies to: