"api-ms-win-downlevel-kernel32-l1-1-0.dll" is missing error when starting Epic Games Launcher

Hope it's the right place

I've been using Epic Games for years without issues but yesterday starting its launcher I got an error message stating that "api-ms-win-downlevel-kernel32-l1-1-0.dll" was missing.

Re-installation of the client made no difference *

Got in touch with Epic Games tech support and was advised to reinstall visual c++ 2015 redistributable (both 32 & 64 bit) but nothing changed

Even tried manually copying that missing dll to C:\Program Files (x86)\Epic Games\Launcher\Engine\Binaries ....  but no luck

I'm pretty sure I have all

Pretty sure I have all the "necessary" .net packages as you can see below

Any help is appreciated

Thanks

*Mind that installed games seems to work fine. I quickly tried The Outer Worlds & Mechwarrior 5 that I have on Epic and they started just fine.

PS Do not suggest to use Windows 10 .... I have it on a different drive on this same pc

Answer
Answer

10 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated May 1, 2021 Views 16,676 Applies to: