Windows trusted installer denying access to files

I have a home-built computer running Windows 7 pro 64bit.  I own the computer in every way, I use it as a personal computer.  In the process of of installing windows 7 I used the Windows easy transfer wizard to transfer all of my files over to an external hard drive.  When I had finished installing Windows 7 is used the Windows Easy Transfer Wizard to transfer my files back to the computer.  In the process it transfered my old program files which I don't need any more to the computer.  I tried to delete them as they were taking up space on the computer's hard drive and was subsequently told that I didn't have the authorization to delete them and that I would need to get permission from windows trusted installer.  As mentioned at the top of this post I own this computer, it's sitting in my bedroom.  My question is "what do I have to do to change the permissions"? I tried changing them through the properties of the afore mentioned program files but all options necessary to change them were grayed out, making me unable to select them.  Why am I unable to change settings on my own computer when run as the administrator?  
 

Question Info


Last updated September 22, 2019 Views 540,866 Applies to:
Answer
Answer

It's funny that I spent all that time to write a guide on getting past the permissions and posted it in another thread on the subject but I didn't post it in my own thread.  Well, here it is:

 

"Also, here is my step by step process for reclaiming the right to delete and move files.  Note: DO NOT change the permissions of the Windows folder using the following method.  Should you need permissions to edit files in the Windows folder, change them individually.  Windows Backup can be irreparably (as far as I know) broken by such a change.  LEAVE THE WINDOWS FOLDER ALONE UNLESS YOU KNOW EXACTLY WHAT FILE YOU NEED ACCESS TO.

 

1) Click the start menu and open Computer.

 

2)Click on the drive that contains the file you are trying to move/delete.

 

3)Right click on the folder that contains the file you are trying to move/delete. Select Properties.

 

4)Click on the Security tab.

 

5)Under the box containing the permissions each entity has, click on Advanced.

 

6)In the new Advanced Security Settings window, click on the Owner tab.

 

7)In the owner tab, click on the Edit button.

 

8)In the new window, you should see "Current Owner:" over a box with (most likely) trusted installer in it.  Under that you should see "Change Owner to:" followed by a short list of possible owners. 

 

8a)If you see your username (listed as [Name] (My-PC\[Name])), then click on it and check the box below the Other users which says "Replace owner on subcontainers and objects".

 

8b)If you do not see your username, click on the "Other users" button. From there, enter your username into the space provided and click Check names. The username you typed should then get underlined and expanded.  Then click Ok. From there follow step 8a.

 

9)Click Apply.

 

10) Now close all windows opened from the properties window and close the properties window.  Reopen it, and under the box entitled "Group or user names," Click Edit.

 

11)If you do not see your username, as chances are you won't, click add.  In the add window, type your username into the given space and click the Check names button. Your username should become underlined and expanded to include the computer name.  Then click OK. (I typically just click OK but if for some reason it doesn't work for you, at least you will know at what step you were tripped up.)

 

12)Upon clicking OK, the Select User or Groups window will close and you should see you username has joined the other names in the Group or User names box. Click it, and then check the "Full Control" check box lower down.  This will grant you complete permissions for everything except "Special Permissions".  This is normal, and so far I have not found a way to check that checkbox but it hasn't presented itself as a problem yet so I wouldn't worry about it.

 

13)Click Apply. You should see a window pop up saying "Changing Permissions" and file locations rapidly going by. This is normal and it means that the folder, subfolders, and files are having their permissions changed. 

 

Alternatively, after closing and reopening the properties of the folder you want to change, you can click on the Advanced button again and then the Change Permissions button and follow similar steps once there.  This also allows you to create inheritable permissions. That is a whole new can of worms that I don't understand, so I just leave the checkboxes blank.

AGAIN, DO NOT CHANGE THE PERMISSIONS OF THE WINDOWS FOLDER. THIS COULD CAUSE A WHOLE HOST OF NEW PROBLEMS, ONE OF THEM BEING BROKEN WINDOWS BACKUP.

 

Oh, and if you want, you can completely remove Trusted Installer from the permissions.  I can't say what the benefit is, but it's satisfying.

 

I hope this helps some of you."

65 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Hello
Welcome to Microsoft answers

I would suggest you to modify the permission settings on the folder or the hard drive on which you are unable to create or modify or delete files.

Follow the below Steps:

1. Right click on the file or directory.
2. Click on “Properties” on the right click menu.
3. Click on “Security” tab.
4. Click on “Advanced” button at the bottom.
5. In Advanced Security Dialog window, click on “Owner” tab.
6. Here you will be able to see current owner (i.e. Trusted Installer).
7. To take ownership of the object, click on the Edit button. Give permission to UAC. Then highlight the user name in the “Change owner to” box that you want to assign as the owner for the object. Click “OK” to finish the process.
8. Back in Advanced Security Settings window, you will see the current owner has changed to the user you just selected.
9. Click “OK” button to exit this window.
10. Click “OK” again to exit completely from the Properties window.
11. Repeat step 1 to 4 to open the object’s Properties window again.
12. Back in object’s Properties window, click on Edit button, and confirm the UAC elevation request.
13. Highlight the Administrators in the “Group or user names” box. If the user ID or group that you want to manage the permissions for the object doesn’t exist, click on “Add” button, and type in the user name or group name desired into the “Enter object names to select (Can use Everyone as user Name)” box, and finish off by clicking on “OK”.
14. In the Permissions for Administrators box below (or any other user name or group name you chose), click on “Full Control” under the “Allow” column to assign full access rights control permissions to Administrators group.

Also refer this link
http://windows.microsoft.com/en-us/windows-vista/Troubleshoot-access-denied-when-opening-files-or-folders
 
Hope it helps
Thanks and regards
Dinesh-Microsoft Support
Visit our Microsoft Answers Feedback Forum and let us know what you think
http://social.answers.microsoft.com/Forums/en-US/answersfeedback/threads/

 

 

38 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.