Windows could not start the Windows Search service on Local Computer

Ok so this is a big, messy and convoluted problem so please bear with me. Any help is greatly appreciated.

I'm on Windows 7 Professional 64-bit
UAC is set at the 2nd lowest level

The other day I was having problems with the search box in the start bar. It was no longer finding excel or other office apps, and also it could not run basic commands like cmd, or notepad. Whenever I ran a command it would return an error similar to this:

windows cannot find 'search:query=cmd'

I poked around a bit and tried to rebuild the index in Control Panel > Indexing Options. That did not work so I uninstalled Windows Search and reinstalled it. What i found now was that the Indexing service would not start anymore and if I manually tried to start it from services.msc I would get the following error:

Windows could not start the Windows Search service on Local Computer
Error 161: the specified path is invalid


The Event Log showed me this Application Error:

The gatherer service cannot be initialized.

Details:

The Temp folder is on a drive that is full or is inaccessible. Free up space on the drive or verify that you have write permission on the Temp folder. (HRESULT : 0x80070660) (0x80070660)


 

Question Info


Last updated March 24, 2020 Views 84,671 Applies to:
Answer
Answer
Thank you Samhrutha.
Your proposed solution of editing the Registry is the only solution I've found so far that consistently works.
The only caveat I would note is that this fix results in windows search being completely reset to it's default settings.  Any search customizations what have been made by the user (e.g., user customizations to windows search indexing options) will be lost.

I am running Windows 7 Pro 64-bit, and on occasion have experienced the same error message (
windows cannot find 'search:query=XXX', where XXX is my search query) when attempting to initiate a search via the Windows start menu search box.

Only just recently, however, have I discovered another possible cause/fix to this issue.
More specifically, I have discovered that the windows search error occurs as a result of ADDING A NETWORK LOCATION to the local computer (e.g., via the "Add a network location" menu option which appears when clicking on the File menu in a windows explorer window displaying contents of the local computer (corresponding to the "COMPUTER" icon). The SYNC CENTER settings of my computer have been set to disable syncing of network or "offline" files, and I suspect that this setting is also part of the cause of the search error.

To fix this issue, one simply needs to tell windows search not to include the "network location" in the search index.  To do this, one needs to access the settings of the windows search INDEX LOCATIONS (via Indexing Options->Modify) and then uncheck the box corresponding to the network location (which on my computer begins as follows: oneindex://{s-1-5-21.....

After unchecking this box, click on OK button, and then CLOSE button to exit out of the Index Options windows.  After that the error message should hopefully not return.  If it does, try restarting the computer and test search again.

Hope this helps!!

:)

~rx

19 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.