Windows 7 Search is not working correctly

I am running Windows 7 Professional (64 bit) with Office 2007. Computer has a Core2Duo processor with 8 GB memory.

Windows search is not working properly.

  • A search in Word/Excel 2007 (when trying to open a file) does not display any results, only category headers under "Search again in". Only when selecting search again in "My Computer" will any files be displayed from the "My Documents" folder.
  • Search in Outlook 2007 works fine.
  • When using search from the "Start Menu", no files from "My Documents" folder will be displayed, but files from everywhere else will be shown. Doing the same search then by clicking on "My Computer", only the files from "My Documents" folder will be displayed.

I have tried the rebuilding the index, the hotfix, the registry change of "GroupBy" and the registry key deletions under [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows Search] with subsequent rebuilding of the Index. Nothing works.

Any help is greatly appreciated. Thanks in advance!

|
Answer
Answer

Hi Paul:

You solved it. No, not with the "Allow this file to have contents indexed in addition to file properties". The files and folders had the setting checked.

BUT, I noticed the files (and not the folders) had also been set to "File is ready for archiving". I did not consciously do this, and, as I said, the files are in folders which do not have that option checked - go figure! I do not archive files nor folders.

So, I unchecked the "File is ready for archiving" option for the files in the folder I am searching the most. Search now works perfectly for that folder.

How can I uncheck this option for all files in all folders (without doing so one by one - again, the folders are not checked for that option, only the files in those folders show "File is ready for archiving"?

Thanks in advance,

Wolfgang

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Answer
Answer

Hi Wolfgang,

Could you verify that for the specific files that are not showing up in search have the following property set?

Goto-->properties-->general tab-->advanced

Make sure there is a check in the box labeled "Allow this file to have contents indexed in addition to file properties"

Paul


Paul LeBlanc MSFT

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated November 15, 2020 Views 15,303 Applies to: