Windows 7, Deleting Large files is extremely slow. (Not going to recycle bin, permanent delete)

It is taking a huge amount of time to delete files.

The files are not going to recycle bin (I am hold shift while hitting the Delete key)
Also I have even tried shutting off the recycle bin

I have timed a few of these

Single file delete, 2.6 gb, 2 minutes 14 seconds
Single file delete, 1.9 gb, 1 minutes 44 seconds
Single file delete, 230 mb, 0 minutes 24 seconds

Most of the time the dialog window that pops up says "Calculating..."

Judging by the times, This has something to do with file size.
I get similar time when I delete from the command prompt.

Windows XP would do permanent deletes and moves (on the same drive) in a split second, especially since we are talking about one file.
I work with large image files regularly. I can't wait 2 plus minutes every time I delete one of these files when I may have to move or delete a few hundred at a time.

I am getting very frustrated with Windows 7.

 

So far...
I have disabled Remote Differential Compression (RDC)
I have disabled TCP AutoTuning and Receive Side Scaling
                netsh interface tcp set global autotuninglevel=disabled (AND)
                netsh interface tcp set global rss=disabled  (And rebooted)

There are no removable drives, USB devices, or other attached devices other that the keyboard and mouse.

I have disabled
Windows Search and Indexing
I am viewing "Details" only in windows explorer (No Thumbnails)
I have shut off IPv6 support (I read about it somewhere but I believe it was to do with network operations, but I tried it anyway)
Teredo Tunneling Pseudo-Interface is disabled
All Drivers are up to date.
I have completely wiped the drive and reloaded the OS.

This is on a 1tb storage drive, no RAID, 3gb SATA drive (Seagate 7200.12)
Windows 7 64bit (Windows experience is listed as 6.1)
Intel i5 processor with 4gig memory
Fresh install, fast hard drive (OS).
Avast AV
Not much else running

 

Question Info


Last updated May 27, 2020 Views 68,692 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello
Thank you for writing to Microsoft Forums.

(A). When deleting a file, the calculation time depends on not only the file size but the file number of its folder. It is recommended to separate to multiple sub-folders if you have a large number of video/music files.

In addition, the issue can be related to third-party codec’s or third-party components, especially file system filter drivers, such as anti-virus drivers.

You can boot the system into Safe Mode and have some tests. If Safe Mode works fine, you can then check the startup programs and loaded third-party services by running msconfig
Steps to boot to safe mode:
1. Restart the computer.
2. Immediately after the screen goes blank for the first time, or after the BIOS post ends.
3. Start taping the F8 key repeatedly. The Windows Advanced Options menu appears.
(If the menu does not appear, restart the computer and try again. If the Keyboard has a F-Lock key, it may be necessary to press it first - QUICKLY before pressing the F8 Key. This will have to be done quickly before tapping the F8 key repeatedly.)
4. Select safe mode and press enter
5. Try booting to the desktop

Refer this link for more information:
“Start your computer in safe mode”
http://windows.microsoft.com/en-US/windows7/Start-your-computer-in-safe-mode

(B). Run a Virus scan. Refer this link
http://www.microsoft.com/security/malwareremove/default.aspx

Hope it helps
Thanks and regards
Dinesh-Microsoft Support
Visit our Microsoft Answers Feedback Forum and let us know what you think
http://social.answers.microsoft.com/Forums/en-US/answersfeedback/threads/

 

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Here's the process that I used to delete a pesky 370MB mpeg file: right-click on the file, select Properties, then under the General tab select the Advanced button for Attributes, then uncheck both options under the File Attributes section ('File is ready for archiving' and 'Allow this file to have contents indexed in addition to file properties'). After applying these changes, the file can be instantly deleted.

Rudy Stricklan

29 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

They know if there is any solution to this problem??
GT

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Even i have a similar problem

when i am creating any file or folder it takes too loong..........and even after creating a file if i have to rename it

i have to again wait too long. Its really frustrating.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sorry pushed the wrong button in proposing the above as answer.

Here is the Proposed Answer:

  1.  From Computer right click on the file. 

   2.  Click Properties

   3.  Click Advanced

   4.  Under File Attributes uncheck "Allow this file to have contents indexed in addition to file."

I was finally able to delete a 1.3GB image file after doing this.  Nothing else not deleting from Computer or a Command prompt worked.  As soon as I did this the delete worked nearly instantly.  

 Microsoft:  Please check your OS to see if it is trying to index huge image files while trying to move, copy or delete them.  It seems to be.  To say this is a huge waste of people's time is the understatement of the century.

Elaine

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Microsoft just does not get it.  In the reply above the technician suggests you reboot in 'safe' mode. Well after spending a couple hundred dollars on an 'upgrade' from XP I do not expect to be rebooting to safe mode to see if I loaded any programs at startup.  We obviously have a problem. FIX IT. How many end users are computer savy enough to navigate these intricate settings? After almost a year of testing how is it that Dos5.0 , Windows95 and Windows XP works better at the most simple task of copy pasting and deleting than Windows 7. We are retrogressing here not moving forward. As for me I'm installing Ubuntu Lucid Lynx and staying with it.

 

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I agree with the notion that Microsoft should fix this. What is the delete calculating in any case? As a person who deletes a lot of bit files why should I have to go off to lunch to delete a 20GB file?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Boot to safe mode and run a virus scan??? Jeez!

I have been having this problem too, since installing win7.  In addition, after copy operations, many times I will compare the folders with a third party comparison tool like Free Commander, and half of my files were not copied properly.  Glad I didn't delete the original copy!

I will definitely try turning off the archive attribute in my files.  But the "allow indexing" option is kind of needed.  As a matter of fact, the archive attribute is needed for backup software too. What a drag to turn it off before every large operation.

Better yet, however, STOP USING WINDOWS EXPLORER!

Please fix this, and the Bluetooth dongle problem, Microsoft!

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Reply In reply to deleted message
Came to this forum looking for a fix on this issue and it seems the problem has been here since release. File transfer and delete is worse on a usb drive. I'm working from a clean install of windows 7 too. Luckily I dual boot with fedora, so I save the major file deleting and copying for that os. I just find it a hassle to to boot into another os to do a simple operation...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Add me to the list.....

I also have the problem of copy, move, delete being slow beyond belief. My system is a new tosiba laptop with windows 7 pro 64 bit, with an intel i7 processor (would never know it, my other 5 year old laptop running all the same apps and more in 32 bit is way faster, imagine my dissapointment there) anyway. I have tried all of the solutions in this thread and none have helped. I even tried to boot to command prompt and delete using the dos delete command.. all kinds of tweaks and fix's and nothing.... It took 22 hours to delete about 265 gig off of a 400 gig esata hard drive with nothing else on it...... It would have been faster to reformat or so I assume... . Again anyway I don't want too lay blame anywhere but I am glad (but not happy) that there seems to be alot of other people having the same problem.....

Hopfully if everyone who has the problem complains the Microsoft Gods will smile upon us with an admission and fix......?????

Please if anyone finds a solution that even helps a liitle ........ POST IT.........????

All I wanted is to add that after being windws7 for a while I have noticed it is very reliant on third party applications to run usefully! The delete is not the only function lacking!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.