Unable to delete folders on external USB hard drive

There are folders that I can't delete on my external USB hard drive that I'm beginning to suspect are connected to Windows updates associated with Visual Studio that fail each time I try to apply them (that's another issue that I've been waiting in vain for an answer for on Microsoft Connect).  These folders have names like f95b13d78bd4c3a41d86.

Here is an example of the message I get when trying to delete these folders:

You need permission to perform this action.
You require permission from SYSTEM to make changes to this file.
eula.rtf
etc., etc.
 

Question Info


Last updated August 6, 2019 Views 89,833 Applies to:
Answer
Answer

Hi,

1.       Are you logged in as the administrator?

2.       Have you tried deleting the folder as the administrator?

3.       Are you facing any issues with Windows update?

Method 1:

I would suggest you to take full ownership of the folder and then try deleting.

a. Right-click the folder, and choose Properties

b. Click the Security tab

c. Click Advanced, then the Owner tab

d. Click edit, and then your username (make sure to check Replace owner on sub containers..)

e. Click Apply, then OK

f. Now, under Permissions, click Change Permissions

g. Click Add, then type in your username and click OK

h. Check the Allow box under Full Control, then click OK

i. Now choose the Replace all child permission checkbox

j. Click OK, then Apply, then close.

Refer:

Take Ownership of a File or Folder

http://technet.microsoft.com/en-us/library/cc753659.aspx
Rohit Chettri
Forum Moderator

106 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.