Thumbnail preview in explorer not showing thumbnails, instead default program icon

I have tried and checked all things commonly being refered in forum,

windows explorer is not displaying thumbnails ( as it was earlier) instead it is showing default program icon ( windows photo viewer, set as default for all pictures) for all picture files like jpgs, bmps.

when I browse folder containing pictures. at first it displays thumbnails ( as it should ) and then immediately all thumbnails change to default icon.

when I double click any icon, it opens in its associated program correctly

I have checked all the common places like organize folder -> view -> 'always show icons never thumbnails' is unchecked

I have chekced group policy settings

I believe it is some little change in registery, perhaps after running a portable program RIOT -Radical Image Optimization Tool. that is a doubt anyway.

 

please help

 

 

Question Info


Last updated October 19, 2018 Views 84,416 Applies to:
Answer
I found the solution in my case accidentally.  My kids started to play Minecraft on this laptop and I realized immediately that they would do well to have more RAM.  Lo and behold, after upgrading from the stock 2 GB to the max 8 GB, all the thumbnails suddenly appeared successfully and there has been no further problem!  Yay.  It seems to me Windows 7 uses a lot of RAM to the point that 2 GB is not enough for it to perform as advertised.  HTH someone.  

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

Hi Sunny,

 

Windows keeps a copy of all of your picture, video, and document thumbnails so they can be displayed quickly when you open a folder. The thumbnail preview problems can be resolved by clearing the thumbnail database and let the system rebuild it as and when required. To do so, use these steps:

 

Steps to Clear the Thumbnail Cache using Disk Cleanup

a.    Click Start, type “cleanmgr” (or typedisk cleanup) without quotes and press {ENTER}

b.    Select the system drive letter from the drop-down.

c.    Uncheck all the entries, except Thumbnails

d.    Click OK, and click Delete Files to confirm.

 

Alternatively, you can build thumbnail cache by going to the location below

%LocalAppData%\Microsoft\Windows\Explorer

 

The thumbnail database is stored globally in Windows 7 & Windows Vista, unlike Windows XP, where the thumbnail database is stored on a per-folder basis. In Windows 7 & Windows Vista, the default thumbnail cache location is as mentioned above.

 

Hope this information is helpful and let me know if you need any further assistance.

Mouneshwar R – Microsoft Support

-------------------------------------------------------------------------------------------------------------------------

Visit ourMicrosoft Answers Feedback Forum and let us know what you think


[If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]

32 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.