Suddenly can't drag or drop files anymore in windows 7 (64 bit)

Hi Everyone,

I have a new Windows 7 Home Premium (64 bit) laptop. I've not installed any new programs (auto-updates either) or what I know changed any settings, but suddenly today I can no longer drag and drop files on my laptop... this is everywhere, but most noticeably on the desktop, where I usually put files and group then where I want. If I want to move files from the desktop to My Documents I have to now cut and paste them!!!

What is going on?

Have I inadvertently changed a setting? How do I get this function back as it is vital!!

Sincerely, and with thanks,

Judd
 

Question Info


Last updated November 13, 2018 Views 170,623 Applies to:
Answer

This sounds too simple to work, but it worked for me:

 

1)  Find an affected icon.

2)  Click and HOLD the icon with the Left mouse button.

3)  Press Esc while holding the Left mouse button.

 

That's it!  This was driving me crazy.  It had nothing to do with registry entries or anything else.  Simply a failed Drag & Drop operation that hadn't exited.  Even restarting had only worked temporarily, so I suspect my Esc key may have been stuck down or at least the system thought it was!

 

My particular variant of this problem seems to stem from either a Virtual Machine taking mouse focus, or a browser window (I was running a VM inside a browser window) then being interrupted during mouse action.

 

Thanks to @_Nige for the quick fix.

http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/drag-and-drop-not-working-in-windows-7/f6dcfa11-8c51-e011-8dfc-68b599b31bf5?tm=1341168619214

1032 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.