• July 17, 2017
    Announcement: New site design for Microsoft Community

    In July, Microsoft will roll out the first of ongoing site improvements aimed to modernize Microsoft Community and help customers get the most out of their community experience.

    • During the roll out period, you may see the old or new site design depending on your location

    • We expect the roll out to finish by 31 July

    Note: Past private message conversations will not move to the new site design. Please save any private messages you would like to keep.

     Learn more about the upcoming site improvements in this thread.

    Thank you for being part of Microsoft Community!

 
Question
114165 views

Offline files - access is denied

MiroIT asked on
Hello. I have this problem.
I have Windows 7 PRO and when i try to make some directories available offline i get messge in sync center - Access is denied on almost every file...then i cannot access to these files...i cannot open/copy,move,delete these files (it seems like i dont have permission on it, but i have it). So i tried to solve this problem (many hours).

I only managed these solutions:
1/ when i turned off offline files in sync center and then i restarted OS, everything was OK. I could open, change, delete, copy, etc..every file. BUT i dont have these files oflline. O:(
2/ i tried many steps, like completly delete offline files or i deleted CSC folder on windows folder...but nothing...everytime as i turned on offline files and some direcotries on server i made available offline, there was the same problem...ACCESS IS DENIES

I have tried to find solution on many portals but nothing (i found some problems with this problem on Vista, and there was a repair KB, but for Win 7 isnt it...)

Please help me.
Is this officialy bug on Windows 7?
Is this problem on PC or on server (i think this is problem on Win 7)? We have these problems on every PC in our company...
We have Windows Server 2008 R2.

Many thanks

 
58 people had this question

Abuse history


The answered status icon Answer
Tony Gore replied on

EUREKA

I have found the solution (in my case) and think I have deduced the cause.

The solution was that encryption had been turned on under the one profile i.e. the normal user profile but not under any other profile. Once this is turned off, it worked again. Don't be confused and think that if you have not enabled encryption on your disk then offline file encryption is disabled. The two are totally independent.

NOW - to how did it happen?

With the setting so deeply buried, and I am methodical about logging changes I make, there is no way I made that change (i.e. turn encryption on) manually.

But of course, I was roaming. And every time you connect to a new network, you are asked whether the network is public/home/office and then it goes and changes some security settings. I think it is this "new network security settings" that made the change. It is quite possible that the behaviour was changed in a recent patch - the change of security settings like this would most likely not be advertised and might not even have been intentional.

Lessons learned

1) If, when you are roaming, your offline files become read only i.e. you cannot write changes back or store new files in the folders with a permissions error, then go to the sync center => manage offline files => encryption tab; if "unencrypt" is greyed out, then you have a different problem. If "unencrypt" is not greyed out i.e. can be enabled, then click this to turn encryption off.

2) The logic of this is that you cannot sync encrypted files. And if you do encrypt them, they become read only and you cannot save new files in the offline folders.

3) Permission errors (in this case) throw you off in completely the wrong direction. It was only due to the fact I have several laptops all with the same user that I was able to pin it down to the laptop/user combination.

4) To scare you, you can still see the files, but often they indicate 0 bytes in size. This is another hint that it is not permissions, but something else (permissions normally prevent the files being seen, unless special permissions for traversal etc have been set up)

5) If ANYTHING behaves differently after roaming, look further into what the public/home/work network selection mah have changed

8 people found this helpful

Abuse history


The answered status icon Answer
TechyTim replied on

Hi!

I've never used these forums before so please strike me down if I do something I shouldn't.
(Edit: Just found I have used them before, well what do you know)

 

I know this is an old post but I've found the answer!!  I've spent 2 whole days looking for a solution to this problem covering along the way:


I came across the answer in a Experts Exchange question , simply disable encryption of offline files:

  1. Open Sync Center - Start | Accessories | Sync Center
  2. Click 'Manage offline files' on the left hand side
  3. Click the 'Encryption' tab
  4. Click 'Unencrypt'


For me I just changed my group policy settings for the domain under Computer Management > Policies > Administrative Templates > Network > Offline Files >  Encrypt the Offline Files cache.

For this settings to take effect I believe you must re-initialise the client side cache (offline files store).  In Windows Vista/7 you must do this in the registry as the old method of holding CTRL+SHIFT as you click 'Delete temporary files' doesn't work:

  1. Navigate to the following location in the registry:  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc\Parameters
  2. Create a new DWORDValue called FormatDatabase , with the value 1
  3. Reboot (the new key will delete itself after rebooting along with the Offline cache)

 

1 person found this helpful

Abuse history


progress