missing ntmsapi.dll when operating ntbackup.exe on windows 7 to retrieve my data from windows xp ntbackup utility

Good morning, I was able to download ntbackup.exe on my computer I just upgraded to windows 7 from windows xp.  However, I cannot use the ntbackup.exe in windows 7.  But when I did, now I am unable to operate it because the error message says missing ntmsapi.dll.  Can you guys send me the file or tell me where I can get it.  

Best Regards,  Emmanuel
 

Question Info


Last updated February 1, 2019 Views 6,314 Applies to:
Answer
Answer
Good morning, I was able to download ntbackup.exe on my computer I just upgraded to windows 7 from windows xp.  However, I cannot use the ntbackup.exe in windows 7.  But when I did, now I am unable to operate it because the error message says missing ntmsapi.dll.  Can you guys send me the file or tell me where I can get it.  

Best Regards,  Emmanuel
Hello,

Windows 7 / 2008 R2 does NOT use NTBackup.exe to back up files. Instead, it uses SDCLT.exe (located at %SystemRoot%\System32\sdclt.exe) which depends on Volume Shadow Copy service. 

If you would like to install NTBackup.exe anyways, you'll need the following files which you can get from your Windows XP CD cabinet nt5backup.cab or you can download them from the internet then copy the files to a new folder (e.g Copy the following files to %ProgramFiles%\NTBackup)
  • Ntbackup.exe
  • Ntmsapi.dll
  • Vssapi.dll
  • Ntbackup.chm
  • Ntbackup.hlp

If you have an existing copy of Windows XP already installed, please copy the following copy to a new folder (e.g Copy the following files to %ProgramFiles%\NTBackup)
  • %SystemRoot%\System32\Ntbackup.exe
  • %SystemRoot%\System32\Ntmsapi.dll
  • %SystemRoot%\System32\Vssapi.dll
  • %SystemRoot%\Help\Ntbackup.chm
  • %SystemRoot%\Help\Ntbackup.hlp

REMARK: You may receive the following error while starting NTBackup.exe on Windows 7. This error can be safely ignored

The Backup Utility cannot connect to the Removable Storage service. This service is required for use of tape drives and other backup devices.

Please exit and start the Removable Storage service using the System Services function of the management console.


Thanks,
I hope this helps :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.