Folder Delete Error No longer located in

I have a folder called books that is empty, but when I try to delete it I get a error massage saying:

Could not find this item

This is no longer located in C:\users\jerry\My Documents\Our Stuff\My eBooks. It gives me two actions: try again and cancel. Any ideas on how to remove this folder?

 

|
Answer
Answer

I've had this problem many times, first with Vista and now with Win7! Instead of bringing out new O/S and new versions of IE etc, maybe Microsoft want to develope fixes for the software we've already paid for!!

If it's a folder that cant be found, Usually you can access the items inside that folder, so if you need to keep them, copy them and paste them somewhere else then delete the folder  

I use this method to delete

Lets say the file/folder you cannot delete is C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Monopoly

> Open an Administrator:Command Prompt by right-clicking on Command Prompt and
> choosing Run as Administrator.  Enter:
> cd "C:\ProgramData\Microsoft\Windows\Start Menu\Programs"
>
> That should leave you at the Command Prompt and in that folder; you should
> see:
> C:\ProgramData\Microsoft\Windows\Start Menu\Programs>
>
> Enter:
> dir /x /a
>
> This is the good ol' Dir command from back when folders were Directories,
> with two switches.  (In a Command Prompt window, type the command name
> followed by /? to see mini-Help file showing the switches and parameters
> that can be used with that command:  dir /?)  The /a shows All files and
> folders, even those with Hidden or other attributes.  And the /x switch
> inserts a column between the file size and the LFN (Long File Name) showing
> the SFN (Short File Name), also known as the 8.3 filename, for each file and
> folder.  Long before LFNs were allowed, MS-DOS required every filename to be
> no more than 8 characters, plus an optional extension of no more than 3
> characters, and some characters were not allowed.  But EVERY file and folder
> had to have a name that was "legal" by these requirements.  Even after LFNs
> were invented, every filename still must be convertible into a valid SFN.
>
> In a Command Prompt window, we can use these SFNs, even when we are not sure
> of the LFN.
>
> So, find that Monopoly entry in the directory listing and note its SFN.
> Maybe it's "monopo~1".  If it is a single file, then enter:
> del monopo~1
>
> If it is a folder, then:
> rd monopo~1 /s
>
> This rd (Remove Directory) command, with the /s switch, will remove the
> folder, plus all its files and subfolders, so you will be asked to confirm
> that you really want to do this.

 

Hope that helps

Steve

358 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Answer
Answer

Hi JerryAnd,

Welcome to Microsoft Answers!

Are you logged in as an administrator?

From which location are you trying to delete the folder?

I would suggest you to delete the folder in Safe Mode and check.

1.      Remove all floppy disks, CDs, and DVDs from your computer, and then restart your computer.

Click the Start button, click the arrow next to the Shut Down button, and then click Restart.

2.      Do one of the following:

·         If your computer has a single operating system installed, press and hold the F8 key as your computer restarts. You need to press F8 before the Windows logo appears. If the Windows logo appears, you'll need to try again by waiting until the Windows logon prompt appears, and then shutting down and restarting your computer.

·         If your computer has more than one operating system, use the arrow keys to highlight the operating system you want to start in safe mode, and then press F8.

3.      On the Advanced Boot Options screen, use the arrow keys to highlight the safe mode option you want, and then press Enter.

4.      Log on to your computer with a user account that has administrator rights.

When your computer is in safe mode, you'll see the words Safe Mode in the corners of your monitor. To exit safe mode, restart your computer and let Windows start normally.

 

For further information, visit the below mentioned link:

http://windows.microsoft.com/en-US/windows7/Start-your-computer-in-safe-mode

 

I would suggest you to run Windows Security Essentials and check for Trojans.

http://www.microsoft.com/Security_Essentials/


You may also run Disk Clean up.

http://windows.microsoft.com/en-US/windows7/Start-Disk-Cleanup

 

 

 Hope this information helped!

 Thanks and regards

 Fouzan – Microsoft support

 Visit our Microsoft Answers Feedback Forum 

 http://social.answers.microsoft.com/Forums/en- US/answersfeedback/threads/ and let 

 us know what you think.

25 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated July 8, 2021 Views 174,265 Applies to: