Question

Q: External Hard Drive "is not accessible. Access is denied."

 

Hello people:


Today I really need your help. For the past week I have been doing nothing but only tagging my music files which I have in my Western Digital 1TB HDD. Two days I ago I started to notice that some songs wouldn't play half way through or sometimes when I put some songs to play on VLC it would instead play a video which I have somewhere in my external hard drive as well but in a complete different folder location.


My simple solution at first was to unplug and plug back my external HDD (via USB 2.0) and everything would be OK (songs would play correctly). Then yesterday the same thing happened but now this time I could not delete or create any folder inside my WD HDD. I googled for some answers to my problem and I kept reading about the error-checking tool (Properties > Tools > Check Now) so I performed that. Everything was fine after that. Then later on that day I had the same problem and I performed again the error-checking tool process but this time I noticed it took longer!


After that my nightmare started!


Even though my Western Digital 1TB external hard drive was/is visible (icon) in Explorer, I could not access/open it. This pop-up would say "I:\ is not accessible. Access is denied."

The storage information would not show up either.


I googled now about this same problem and I was very scared because I kept reading other people's problem that maybe the hard drive had died or all data was lost, etc.


This is so far what I've done (in chronological order):


  • I have tried to take ownership of my HDD (probably I didn't do it right, if recommend this please explain (: )
  • I have changed the letter drive for my HDD
  • I have already ran the following command:
  1. chkdsk /r I:
  • I have tried to access my Western Digital external HDD in both my Windows 7 Ultimate desktop computer (where it all started) and my laptop which runs Windows 7 Home Premium


Just now, I booted in safe mode and voila! I CAN access my external hard drive  :D . It seems that the chkdsk command deleted some files :/ because I cannot open a certain folder nevertheless, the most important files are safe!


Now, I've come across many "solutions" but since I don't want to make things worse, I rather wait for your feedback before proceeding doing the following:

 

The problem IS, after all, 'Permissions'. 

Permissions need to be set, not only under 'Sharing', but more importantly, 'Security' / 'Advanced'. 

On the system that your MyBook was originally installed on, right-click the folder on the drive which you wish to permit access to from other systems, select 'Security' and select 'Advanced'. 

Create a new user 'Everyone' and give 'Full Control' to this new user. 

The drive will then be available on other systems as mine now is. 

Phew!


Source: http://www.fixya.com/support/t203995-local_disk_d_not_accessible_access

 

------

I recommend that you try the following method.


1. Right-click on the drive. Choose Properties. 

2. Click the Security tab. 

3. Click the button Advanced. 

4. Click the button Edit. 

5. Double-click on one permission entry.  

6. Give it full control right, and check the box “Apply these permissions to objects and/or containers within this container only”.


Source: http://social.technet.microsoft.com/Forums/en-US/w7itprohardware/thread/9cf46555-578a-4899-8df9-e893036cc574

 

------

To fix this, you can follow these steps: 

1. Click Start , click All programs , and click Accessories . 

2. Right-click Command Prompt and click Run as administrator .

3. In Administrator: Command Prompt window, 

4. Type 

takeown /F (external drive letter) and press Enter.

5. Type 

CACLS (external drive letter) /G Administrator:F  and press Enter.


Note: Administrator can be change to your local user account with the administrator permission


7. Restart the computer and test the issue.


Source: http://social.answers.microsoft.com/Forums/en-US/w7security/thread/a534c0e9-0f19-4d1a-be93-52d7b1a0e922

 

Btw .. I am the Administrator in my computer.

Thanks in advance!


~astroX

 

Answer

A:

Pretty much what you are looking for. You might also be interested in this link.

You cannot rule out the handiwork of a third party software. Perform clean boot to determine if that is the case.

Also, your external drive may have been infected. Run virus check.


The man likes to play chess; let's get him some rocks

Did this solve your problem?

Sorry this didn't help.

109 people were helped by this reply



 
Question Info

Views: 294,118 Last updated: July 13, 2018 Applies to: