Q: Cannot change READ ONLY file attributes using Administrator Account This thread is locked from future replies

I have tried windows explorer and a custom program called Directory Opus. I have tried creating several administrator accounts but no luck.

I cannot work with this problem existing.

I need a solution.



I have the exact same issue.  Following the steps above did not work, the folder/subfolders remain Read-Only.  I am the owner of the folder and subfolders.  I'm not even sure how they became Read-Only to begin with.  Setting Read-Only on individual files works properly.  Changing folder settings does not.


According to a Microsoft Knowledge Base post:
You cannot view or change the Read-only or the System attributes of folders
To summarize, Windows ignores System or Read-Only settings on folders (it does not ignore those properties on FILES however).  Individual applications that you are running may not ignore the Read-Only status on a folder and may give an error.  In my situation, an application was attempting to create a new file in a folder that was marked as Read-Only and it honored the RO setting and refused to try to create the new file.

To actually change these attributes, the Properties menu will not work.  From the KB source:

  • If you click Apply changes to this folder only , the Read-only attribute is changed for all the files in the folder. However, the Read-only attribute is not changed for the folder, its subfolders, or any files in its subfolders. If you click Apply changes to this folder, subfolders, and files , the Read-only attribute is changed for all files in the folder and all files in the subfolders. However, the Read-only attribute is not changed for the folder or its subfolders.

In order to change these properties, the user must launch a command line terminal and execute the changes by hand, such as this command:

  • attrib -r +s c:\test

...which will remove the READ-ONLY setting and apply the SYSTEM setting to the folder.  Once again, changing properties of files (including files in subfolders) works as expected with the right-click Properties -> Security menu.

Knowledge Base source:

Bad support, MS.

Did this solve your problem?

Sorry this didn't help.

278 people were helped by this reply

Question Info

Views: 297,212 Last updated: March 19, 2018 Applies to: