An error occurred while applying security information to: J:\ Access is denied. After going from Windows Vista Ultimate 32 bit to Windows 7 Ultimate 64-bit one of my USB drives is not accessible.

So far I have tried the solution I could find, and the suggestion everywhere I look is to set the owner, however, I get this error message when I try to set the owner!

In Disk management the volume looks like a healthy NTFS disk.

The problem is that I can't see any files or folders on the drive after changing OS.
At the computer overview it shows the disk has 93GB free of 931GB size.
If I open the drive in explorer it sais: "The folder is empty"
If I dir from cmd:
J:\>dir
 Volume in drive J is LaCie
 Volume Serial Number is 280D-B6F2

 Directory of J:\

File Not Found

J:\>

I have even tried to enable and log in on the Administrator account to try to set the owner by rightclicking on the drive, Properties->Security->Advanced->Owner->Edit. In here I have tried both selecting Administrators, and my user, checking "Replace owner on subcontainers and objects". All efforts lead to the same error message as initialy described.

Further more I can add that in the Security tab The Administrators group shows as having full access.

Please tell me what I can do to get access to my files back? Or what aditional information is required to solve my problem. thanks.

 

Question Info


Last updated February 27, 2018 Views 9,128 Applies to:
Answer
Answer
Check this Microsoft Link:
http://support.microsoft.com/kb/925196

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.