Error copying to external drive: error code 2 "system cannot find the file specified"

I've been trying to perform a mirror style backup to my external drive of everything in C:\users\.  First of all I tried using Robocopy (my preferred tool) with the command line running as administrator and that failed after copying a few hundred files.  It came up with error code 2, system cannot find the file specified.  I used robocopy c:\users h:\backup_win7 /B /M /E /DCOPY:T /R:0 /XJ

I then tried using the freeware tool FBackup, this also managed to copy a few hundred files before getting stuck in the same way (at a different point).

Finally, I tried picking one set of folders (Pictures) and doing a manual Copy/Paste into the destination directory, this also failed after copying a few hundred files with an error about not finding the file.

The actual files it fails on are nothing special, just regular jpg.  If I create a simple test.txt on the drive it works fine.  The problem only seems to occur with large numbers of files being copied and where it actually fails seems to depend on which tool I use to copy the files.

Each time this problem occurs my system goes into meltdown with massive CPU usage and then Windows won't let me dismount the drive as it insists something is still trying to do something with it.

The only way out is to restart the computer.

I've tried running CHKDSK /R on the external drive (a Seagate Freeagent 1TB drive via USB 2) and no errors were found.  The drive in question worked perfectly with XP SP3 for several months and has no problems reading from files in Windows 7, just this writing issue.  I've also tried turning off all services with MSCONFIG, but that just meant that the external drive wouldn't mount at all.

My system is an Athlon 64 X2 5600+ running at 2.9ghz, with 4GB of DDR2 800 on a MSI K9N V3 motherboard and an NVIDIA 8500 GT graphics card.  The source disk is a 300GB Hitachi SATA drive.  Overall system performance (aside from this issue) seems very good.

I'm using Windows 7 Ultimate 64 bit, installed from a clean install after XP was previously on the disk.

Any ideas or help would be much appreciated, as this problem is a bit of a show-stopper for my backups.
 

Question Info


Last updated May 8, 2018 Views 2,633 Applies to:
Answer
Right, solved the problem now.  I swapped round the memory modules so that the newest 2GB module came first in the slots, and the older (higher quality) modules came after and the problem went away.

I'm guessing this is something to do with small differences in the specification of the memory that caused weird side effects through the bios, manifesting into unusual errors in Windows.


Putting the cheapest memory first seemed to give the bios the clue to needed to work correctly with this memory and the side effects went away.

Windows 7 might be light years ahead of its predecessors, but the good old PC hardware is still a pain in the proverbial!! :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.