*.xml file located in System32 folder, is not recognised by Windows

I have a problem concerning an xml document and Windows 7 System32 folder.

 

I have recently installed the latest driver for my nVidia graphics card and one of the files it loads is NvApps.xml into the Windows7 System32 folder.  I also use a programme called nHancer which modifies the nVidia programme for the benefit of MS Flight Simulator X (my hobby).

 

I now find that nHancer cannot load because it cannot find the NvApps.xml file in System32.   If I highlight the NvApps.xml file in System32 and press OPEN or EDIT,  I get the message which says :-   “Windows cannot find “C:\Windows\System32\NvApps.xml’.    Make sure you typed the name correctly, and then try again.”   (Actually, I get this message three layers thick on the screen (i.e. I have to acknowledge it three times before the message disappears from the screen)).  I have found that there are ten *.xml files within System32 and five of them produce the above message and the remaining five all open easily and correctly.   Of the five that Windows ‘Cannot find’ two of them are associated with the nVidia driver and the other three are not in any way connected with that driver.

 

I have also found that if I copy the NvApps.xml file to a different folder or hard drive, then I can open or edit it quite normally and without difficulty.

 

I would be grateful for any advice or comment that about my problem.

 

Peter

 

Question Info


Last updated October 24, 2018 Views 4,768 Applies to:
Answer
Hi Steve,

Having had very little help from Microsoft (and that may be an exaggeration !) concerning this problem and having been answered by two Moderators, neither of whom read my descriptions carefully, I was forced to look elsewhere for some sense.   I went to the original supplier of my PC (even though he did not supply my copy of Windows 7) and he solved it for me.

Firstly, the unwillingness of Windows to 'find' the relevant file in System32 is apparently because that folder is protected in some way because of the large number of files it contains, that are specialist files for Windows and not for the likes of us ordinary mortals to investigate.   I can understand that but surely Microsoft could use a different error report.

Secondly, the person who solved things for me visited the download that contained the file in question - in my case, NvApps.xml - and identified the cab, or similar, file that contained the file NvApps.xm_  (It was in an earlier driver for my graphics card)   This is a type of compressed file (rather like a zip file, I think).   He went into DOS and "expand"ed the *.xm_ file, then inserted it into System32 and when advised that there was already a file of the name NvApps.xml, told it to overwrite it.   That solved the problem.

The clue for him, was that nHancer repeatedly said there was an error and ended with the phrase (xxx,47).   Apparently this told him the error was character 47 in line xxx and, in turn that told him the file was incorrect.   So he changed it for an earlier version in a download I already had.

Hey presto.   All well.

I hope this helps you, and anyone else who has seen the thread and thinks they have a similar problem - but no thanks to Microsoft.

Peter

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.