From XP PC I can't access some drives but can access other drives on the same WIN7 PC

I have done a clean Win 7 64 bit install on C Drive on my PC that used to be XP. The hard drive has two partitions C drive and D drive. The Win 7 PC also has two other hard drives installed each with a single partition (E Drive and V Drive). The hard drives are not RAID configered. The E and V drives were not involved in the Win7 installation and therefore still have their XP configeration.
Prior to installing Win 7 all partitions on all hard drives on the PC were accessible on the three other XP machines on my "Workgroup" home network.
On the Win7 machine I can access all drives on all of the XP machines.
On any of the XP machines I can access the E and V drives on the Win7 machine.
When I try to access the Win7 C drive or D drive from any of the XP machines I get:
"\\PC\PC (x) Drive is not accessible. You might not have permission to use this network resource" Where (x) is either C or D depending on what drive was accessed.
I have tried unsharing and resharing the C and D drive. I have also compared the Property settings between the C and D drives that I can't access with the E and V drives that are accessible. Those setting are the same.
Please advise any thoughts on what can be done to render my C and D drives accessible on my network XP PCs.
 

Question Info


Last updated February 27, 2018 Views 699 Applies to:
Answer
Hi Ken,     
 
Important:  This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
 
How to back up and restore the registry in Windows: http://support.microsoft.com/kb/322756
 
Try these steps on windows 7 computer and check if this helps.
 
1. Click on start button and select Control Panel>System and Security>Administrative Tools>Local Security Policy.
2. Click on Local Policies -> User Rights Assignment on the left.
3. Double-click "Deny access to this computer from network".
4. Select Guest and click Remove.
5. click OK.
6. EDIT: Ensure in the Permissions for the network share, that Guest is included, since it's no longer part of the Everyone group.
7. Click on start button, type regedit and press enter.
8. Go to the following path HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System and create or modify the value of LocalAccountTokenFilterPolicy (32-bit dword) to 1, so the remote logon token will not be filtered.

You may also view similar issues and check if this helps.
http://social.answers.microsoft.com/Forums/en-US/vistanetworking/thread/e27f98fc-06b1-4d51-88f0-1e930c0eb035
http://social.answers.microsoft.com/Forums/en-US/w7network/thread/0bf24c2e-8a28-4dd6-8457-da15e74fd597

Hope this information is helpful.
 
Umesh P - Microsoft Support

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.