Why can't the Admin be the admin?

In Windows 7, I sometimes attempt to install software. That is a basic function of an OS, which I think I should be entitled to do. However, with some programs, the installer gets denied access because "Access to the directory is denied". I try to take away the read-only status on my folders, but no, access is denied. It says my administrator should do so.

But, I AM THE ADMINISTRATOR. Why can't I be the administrator of my own PC? Why is it not up to ME if the folder should be protected or not?

Is there a way to get rid of this? Because disabling UAC doesn't help, and when it is off my Security Center nags about it day in and day out. I just want to install SandBox2 for Crysis for god's sake...
 
Question Info

Last updated February 27, 2018 Views 731 Applies to:
Answer
Yes, I have tried that, and the option "Run as administrator" is not available. However, that that makes it non-compatible is not true, since many other applications lack that options but have installed just nicely. Furthermore it is a Crysis-app, made for Vista, and if it works with Vista it should work with Windows 7 aswell.

Though, I did solve it. Just un-ticking the "read-only" was obviously too simple for the OS, and some more advanced management in the "Security" tab fixed it. I added extra privileges for installers and regular users, and then the program could install.

And now, it runs nicely. Why Windows couldn't just complete the simplest task I gave it remains a riddle, since XP had no such problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.