Windows 7 Aero is not working after restart (option greyed out) - tried nearly everything!

Aero themes were working perfectly until my  boyfriend uninstalled jZip from the computer (since it kept trying to install a toolbar). When he restarted the computer, the computer had reverted to the classic windows theme and we were unable to switch it back. Itunes also refused to open until I removed a blank disc from the disc drive, not sure if that's related or just another crazy thing my computer did today. When I tried to switch back to an aero theme, the icons are greyed out in the Personalization menu. I went online to search for fixes, here's what I've tried:

1) I tried restarting the computer.

2) I ran the aero themes troubleshooter. It found no issues.

3) I went into the Services menu and made sure that the System Event Notification Service was started and automatic. It is.

4) I ran the Window Experience Index. It rated a 6.3 for Graphics (desktop performance for Windows Aero). Lowest score in any area was 5.9 (in Primary hard disk, disk data transfer rate).

5) I ran the system file checker (sfc /scannow) and no issues were found.

6) I attempted to force start Aero using the following notepad document turned .reg file:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM]

“UseMachineCheck”=dword:00000000

“Blur”=dword:00000000

“Animations”=dword:00000000

7) I created another user on the computer and Aero works just fine if I switch into the other user. This shows me that my computer can handle aero themes but something in my main user/administrator account is messed up.

8) I ran the Microsoft Fix It Online program and it gave me the following error: 
Your video card doesn't support DirectX 9.0 or higher, Pixel Shader Model 2.0 or higher, or doesn't have sufficient memory or memory bandwidth required to display Aero effects such as transparency.
This seems odd, since the other test user account can display Aero just fine and so was my main user account until very recently.

About my system:
I am running Windows 7 Home Premium with Service Pack 1 on an HP Pavilion dv6 Notebook PC.


 

Question Info


Last updated July 16, 2019 Views 9,837 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi RachaelWD,

 

·         Do you receive any error message or error code?

 

Follow the suggestions listed below for a possible fix:

 

Method 1: I would suggest you to perform clean boot and check if any third party applications are causing the issue.

 

Place the computer in a clean boot state and then check if it helps. You can start Windows by using a minimal set of drivers and startup programs. This kind of startup is known as a "clean boot." A clean boot helps eliminate software conflicts.

 

How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

http://support.microsoft.com/kb/929135

 

Note: After troubleshooting, make sure to set the computer to start as usual as mentioned in Step 7 from the KB article mentioned above.

 

Method 2: There might be an issue with the drivers related to the display adapter on the computer; I suggest that you update the drivers and check.

 

a.       Click on Start.

b.      Type in Device manager in the Start Search.

c.       Expand the Display Adapters in the Device Manager window.

d.      Right click on the device.

e.      Click Properties.

f.        Click on Driver tab.

g.       Click on Update drivers.

h.      Click OK.

 

Now restart the computer and check.

 

Refer the link to update the drivers from Windows Update:

 

Update a driver for hardware that isn't working properly

http://windows.microsoft.com/en-US/windows7/Update-a-driver-for-hardware-that-isnt-working-properly

 

You may also follow the steps in the article for more help:

 

Guided Help: Troubleshoot Aero problems in Windows 7

http://support.microsoft.com/kb/976170

 

Let me know if this worked.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Imran,

I did a clean boot and aero themes are still not working. This means a third party application is not responsible for it's failure, right?

All of the drivers were up to date when I went to update them. Restarted the computer and there is no change.

I already ran the Aero troubleshooter, it was the second thing I tried (as noted above).

When I restart the computer I notice that the font size for the task bar (Start and the date and time in the corner, as well as messages that pop up from the task bar) has changed (it's smaller than usual). I also get an error message:

"Failed to connect to a windows service. Windows could not connect to the System Event Notification Service service. this problem prevents standard users from logging on to the system. As an administrative user, you can review the System Event Log for details about why the service didn't respond." 

So I go to the Services menu and find that the System Event Notification service is started and automatic. I don't know why it's giving me that error.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello RachaelWD,

 

·         Are you logged in as administrator?

 

Follow the suggestions listed below for a possible fix:

 

Method 1: Try performing SFC (System File Checker) scan on the computer.

 

How to use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7

http://support.microsoft.com/kb/929833

 

Method 2: I would also check the status of the issue in a new user account. If the issue does not occur in new user account then, you might want to fix the corrupted user account.

 

Create a user account

http://windows.microsoft.com/en-us/Windows7/Create-a-user-account

 

Fix a corrupted user profile

http://windows.microsoft.com/en-US/Windows7/Fix-a-corrupted-user-profile

 

Let us know the results.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Imran,

Yes, I am logged in as administrator. I've run the SFC before (step 5 in my original post), I ran it again and again no issues were found

I created a secondary user account and aero effects worked fine in it (as noted in step 7 of my original post). I restarted my computer and attempted to log into the secondary account FIRST and the aero effects failed. Seems like the aero effects only work if I log into my primary account first and then switch users to use a secondary user account.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

To confirm -- whatever user profile I log in to first experiences aero failure. Then I can switch to any other user profile and aero works fine within that user. I've tested with 3 different user profiles.

Am I doomed to have a dummy user account to start up into and then switch to mine for the rest of my life? The computer can obviously handle aero, so what is causing this problem?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi RachaelWD,

Your original user account may have become corrupt. You can recover your old user account by copying your files to the new user profile. Once you have done so, go to the old account and rename it. Once you have renamed that account you can name the new account the old user name.

Dena

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've had the same problem on my Dell Vostro... After turning my laptop on (and waiting an unusually long boot-up time), I logged on and the Windows Classic Theme was applied, instead of my usual Windows Aero Theme... I get the same error message saying "Failed to connect to a Windows Service". The Aero themes under Personalization are greyed out and cannot be selected or applied...

Restarting my laptop didnt help.. Theme stayed the same

The only way I've learned to overcome this is by holding down the power button and forcing a full shut down... Then upon restart, I "Start Windows Normally" and the issue is resolved

Would still like to know whats causing this issue though... Is it an issue with Aero, or something else?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It's not. I followed the steps you outlined and it had no effect. Aero effects fails in whichever user account I log into first. Then if I switch to any other user it's functional. 

for example:
Boot up and log in to "User A", aero fails.
Switch to "User B," aero works.
Switch to "User C," aero works.

Restart and log in to "User B," aero fails.
Switch to "User A," aero works.
Switch to "User C," aero works.

Restart and log in to "User C," aero fails
Switch to "User B," aero works.
Switch to "User A," aero works.


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi RachelWD,

This may be a bit of a stretch but lets try Startup Repair. From the what you've described, something during startup is preventing Aero from working on the initial startup. Here are the steps below:

  1. Restart your computer and immediately press on the F8 key until you reach the Advanced Boot Options Menu.
  2. Select Repair your computer, which will bring you to the System Recovery Option Menu
  3. Select Startup Repair
  4. Follow the prompts in the wizard to complete the repair.

Let is know if this helps.

Dena

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Have you tried to this if not try this:-

Step 1:-Go to Manage and then go to 'services' from services and Applications

Step 2:- Search for 'Themes' service and restart it or if stopped start it by right clicking on to it

Step 3:-search for desktop windows  'Desktop Window Manager session manager' service start it and go to properties and set it's start up type to Automatically.

Hope this will solve your issue.........

22 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.