Some desktop icons appear as broken icons

Hi all,

 

I had to reconfigure some connections inside my box, and inadvertently switched the order of my SATA drives.  In short, Windows loaded with my optical and 2nd HDD swapped, so it assigned them letters.  All the icons that looked in D: switched to the "broken" icon.  I've since switched drive letters and rebooted, multiple times.  

Right clicking on the icon and selecting Properties displays the correct icon under the "Shortcut" menu.  How can I get that icon to show on the desktop now?



 

Question Info


Last updated November 2, 2018 Views 37,756 Applies to:
Answer
Hello Drew5764,

It would be beneficial if you could share a screen shot of your desktop icons, and some screen shots of the properties of the application shortcuts that are displaying as broken icons. You can use http://skydrive.live.com to upload your screen shots.

There are a couple of things that you can try:

First: (Rebuild Icon Cache)

    1. Open Folder Options to select (dot) Show hidden files and folders.
    2. Open a Windows Explorer window.
    3. Go to C:\Users\(User Name)\AppData\Local
    4. Right click on IconCache.db and click on Delete.
    5. Click on Yes to confirm the deletion.
NOTE: This deletes the file to the Recycle Bin. It is safe to empty the Recycle Bin when finished.
    6. Close the window.
    7. Empty the Recycle Bin.
    8. Restart the computer.
    9. When you go back, you will notice the Size of the IconCache.db file is smaller, and the  Date Modified is now the current date.
NOTE: If for some reason IconCache.db is not there or the size has not changed much, then just restart the computer again. You may need to restart a couple of times in some cases.
    10. The icon cache has been rebuilt.
    11. Open Folder Options to select (dot) Do not show hidden files and folders.

Second: (Reset Icon Cache)

1. Right click on a empty area of the desktop and click on Personalize.
2. Click on the Display Properties link.
3. Under Colors, select Medium (16-bit) and click on Apply.
NOTE: If you already have Medium (16-bit) selected, then select Highest (32-bit) instead. Sometimes you will need to do a restart first, then proceed to step 4. Try both ways.
    A) Click Yes to confirm the new settings.
4. Now, select Highest (32-bit) and click on OK.
NOTE: If you already have Highest (32-bit)selected, then select Medium (16-bit) instead.
    A) Click on Yes to confirm the new settings.

Hope this helps
Chris.H
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.

25 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.