My Desktop files and shortcuts to folders have disappeared

original title: My Desktop files  (pictures, pdfs, psds, txt etc) as well as shortcuts to folders have disappeared. Where could files go to?

One day it was fine. The next, a whole bunch of icons, files, folders were missing. A few are still there, the others are not. I've been racking my brain for if I installed anything. And I uninstalled those programs. No change. I had files I just used on my desktop and they're gone. Photos, psd files, pdfs, note files, things I need and they're gone!

What could be behind this problem and how do I get them back? The only thing I remember changing was McAfee. It was giving me trouble. I called support. They uninstalled and reinstalled. But they were fine after that. No change until yesterday.



This 6-year-old thread went out of control years ago and is now locked.

The thread includes comments and questions from people with Windows 7, 8, and 10.  Please realize that a solution that works for one version of Windows may not work in another version. 

In general, if the solutions already posted in a thread here in the Microsoft Community do not help you or do not apply to you, rather than adding a post that merely says, "I have the same problem," please ask your own new question in the appropriate section of these forums and give sufficient details about both your system and your problem so that the volunteers here will be able to help you.

For suggestions, please read the following articles:

How to begin your own, new thread about your computer & your problem
How to ask a question



Question Info

Last updated January 16, 2019 Views 85,692 Applies to:

No need for a restore. Thanks for the assistance.
However, somehow loads of programs and files were placed as 'hidden' (not sure how that happened yet)
I was able to fix half of them, still some programs are not accessible. But working through the problem.

For those of you with the same problem.
As all my files and folders have returned! And are fine phew! All is better!


If my memory serves me correctly as It's been quite awhile. I opened 'My Computer" clicked 'Desktop' at the top left. Then I clicked 'Organize' then 'Folder and Search Options' Then 'view' then I looked for 'Hidden files and folders' and selected 'show hidden files folders and drives.' Click 'OK." - That worked for me.

130 people were helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.