Disable all font smoothing in Windows 7 (ie: including taskbar, menus, control panel, etc...)

I would like to completely disable all font smoothing, anti-aliasing, etc... on Windows 7. I find it difficult to read and it gives me a headache.

Here's what I've tried so far:

1. Switched to Windows 7 Basic theme. (No Aero.)
2. Run the ClearType tuner. (It didn't help. I want to remove font smoothing, not tweak it.)
3. Disabled ClearType altogether. (Taskbar, menus, etc... remain smoothed/anti-aliased).
4. Unchecked "Smooth edges of screens fonts" from Performance -> Visual Effects. (Taskbar fonts, help, control panel, etc... remain smoothed).
5. Changed all my fonts to Tahoma under Personalize -> Windows Color
6. Using regedit, added "Tahoma" as the first option under HKLM->Software->Microsoft->Windows NT->Current Version->FontSubstitutes
7. Deleted all Segoe fonts from /Windows/Fonts (Had to take ownership to do so)
8. Deleted nearly all extraneous fonts from /Windows/Fonts (I was getting frustrated...)
9. Tried playing with HKCU->Control Panel->Desktop->   FontSmoothingType (both 1 and 0) and FontSmoothing (both 1 and 0).
10. Tried running my laptop at a non-native resolution (Makes it even worse)

The above steps removed most font smoothing, though the taskbar, dialogue boxes, control panel, etc... remain smoothed/anti-aliased. So far, the only way I've found to completely disable any smoothing is to switch to Classic mode, which has the unfortunate effect of removing any visual styles whatsoever. In short, I want Win7 fonts to render in a binary/completely pixelated fashion, with no gray fuzziness or subpixel rendering.

Please help!
 

Question Info


Last updated September 24, 2018 Views 128,671 Applies to:
Answer
Hi Ken,

   Hopefully the Win 7 typography team will make this "feature" optional by SP1. I'm holding out until then. But if you insist on using 7 before the font smoothing is fixed, here's how to deal with registry font substitutes and UAC/system protection.

   Edit the registry settings under FontSubstitutes so that "Tahoma" appears before Segoe in any FontSubstitute settings. Then, take ownership of the Windows directory (I took ownership of all subdirectories and files, which might be excessive, but made other tweaking easier to deal with) to delete Segoe. To take ownership, right click on the Windows system folder, select "Properties", click on Security, Advanced, then clik on Owner in Advanced security settings... Click on the edit button and change owner to your own account . Make certain "Replace owner on subcontainer..." is checked.

   It's overkill, but will get it done.

R5N

P.S. If anyone does figure out how to remove font smoothing from the Win 7 taskbar, I will praise you for all of time.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.