desktop icons turned into .lnk files

My desktop icons and program links listed in all programs have turned into Windows Media Player .lnk files.  Whenever you try to open them, Media Player opens followed by an error box stating the MP cant run this type of file.  I can access all my files and programs by going to C>programfiles or Documents.  This all happened right after I used the MP to play a DVD for the very first time.  I had used it for viewing pictures and internet files.  I am running Windows 7 Professional with Virtual PC and Windows XP mode.  Thanks for your help
 

Question Info


Last updated October 14, 2018 Views 155,083 Applies to:
Answer

Hi Bradner ,

Clicking on the .Lnk files should open up the associated .exe files. However if the .LNK files doesn’t work, this can be because the underlying .EXE association has been broken often by some programs improperly changing the registry or the association in the registry can become corrupted.

You may try changing the file association from the Control Panel.

Navigate the following location to change the file association.

Start \Control Panel\All Control Panel Items\Default Programs\Set Associations

Instructions on how to change is provided in the link below.

Change which programs Windows uses by default
http://windows.microsoft.com/en-us/windows7/Change-which-programs-Windows-uses-by-default

If that doesn’t help, please follow Sean Zhu’s post on Tuesday, May 19, 2009 6:26 AM from the link below on how to restore the .link file association.

http://social.technet.microsoft.com/Forums/en/itprovistadesktopui/thread/e8631c28-4ce5-43cc-8865-b75fa2255b57

That should do the trick.


Regards,

Shinmila H - Microsoft Support

Visit our Microsoft Answers Feedback Forum and let us know what you think.

12 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.