Context Menu Going Left not Right

When I right click to bring up the context menu and all sub menus in the context menu in any window I have open it goes to the left and not to the right like it normally should. This is highly annoying for me as I am used to the menu going to the right.

 

Does anyone know of a way to fix this? A reg edit perhaps.

I have tried to change my mouse to left handed and then back to right handed but that did not fix my problem.

 

I'm running Windows 7 Ultimate retail.

 

Thanks for any help,

duff

 

Question Info


Last updated September 20, 2018 Views 35,740 Applies to:
Answer

Hi Duff

There are a couple of issues with this behavior. First, if you are clicking very close to the right edge of the monitor, the flyout menus will appear to the left simply because there is not enough room on the right side of the menu.

The other issue is that the 'Handedness' setting has become corrupted or changed. To change this, follow these steps.

Press the Windows logo key+R to bring up the Run dialog box. In the Open line, copy/paste the following text.

shell:::{80F3F1D5-FECA-45F3-BC32-752C152E456E}

Press OK.

This will start the Tablet PC Settings configuration dialog (Even if you do not have a Tablet PC).

Select the Other Tab.

In the Handedness section, place a check mark in the Left Handed option.

Click OK.

This should place the menus on the right side.

Hope this helps.

Thank You for using Windows 7


Ronnie Vernon MVP
MVP 1999 - Present
Windows Insider MVP

352 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.