Can't properly type with Japanese IME on the English Keyboard /Windows 7 English version

Hello, I have a problem with the English Windows 7 Home Premium on the English keyboard when typing Japanese using IME.

No, I should not need the Ultimate edition: with Windows Vista and XP Home Premium or equivalent editions, there wasn't such a problem.

With Windows 7 IME, the keyboard layout seems to be tied to Japanese Keyboard.
For example, if you type [Shift] + [2],
- English Keyboard returns [@]
- Japanese Keyboard returns ["] (double quotation)

I physically have an English keyboard with my PC, and I get ["] when I actually meant to type [@].

As I mentioned, it was perfectly fine with XP or Vista to type with Japanese IME and with the English Keyboard layout. How do I make the same setting with Window 7?

Answer
Answer
Here is how I solved the problem, but I don't really recommend it - MS should distribute a patch to fix it.

1. Open Registry Editor.

2. Go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\i8042prt\Parameters

3. Change the LayerDriver JPN value from kbd106.dll to kbd101.dll

4. Change the value of OverrideKeyboardIdentifier from PCAT_106KEY to PCAT_101KEY

5. Change the value of OverrideKeyboardSubtype from 2 to 0

6. Close the Registry Editor and restart the Windows.

Source:
http://blog.heiichi.com/?eid=792239

As usual, please edit the registry at your own risk.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated September 2, 2020 Views 15,803 Applies to: