Windows 7 support has ended

Get Windows 10 to continue receiving support.

Upgrade now

Can't apply an ICC profile to display; can't understand instructions for color management

I have just upgraded to new clean computer with Windows7 from my old XP machine.  I have icc profiles for both my monitors.  Under XP I had no trouble 'applying' or 'associating' or 'using' these profiles using the MS Color Applet, and both monitors would change appearance during boot to a fully calibrated and profiled state.

Now in Win7 I follow the fairly confusing instructions, go to Color Management / Devices / select one of the displays  / click "use my settings for this device"/ add a profile to the "Profiles associated with this device" box using the "Add" button.  Then I click on the correct profile in that box and click "Set as Default Profile".  Nothing happens.  I can set any bizarre profile as default, and nothing happens.

I don't even know from the instructions WHEN the actual application of that profile is supposed to happen, but assume it is when you click on "Set as Default Profile"

It may be a clue that the Color Management dialog box does not manage to identify my displays other than as 'generic PnP Monitor - NVIDIA GeForce 9800 GT"  whereas the NVIDIA Control Panel and Windows "Screen Resolution" box both manage to identify the displays correctly and use their proper name i,e, Eizo L768 and Samsung SyncMaster.

Also, "Identify display" in the CM dialog box works exactly opposite to how it works in the other two boxes i.e. Samsung (on left) is number 1 in Color Mgmt, but number 2 in the Nvidia Control Panel and Windows "Screen Resolution" box.

I am stymied until I can sort this out, so would be very grateful for any help.

Thanks
 

Question Info


Last updated May 26, 2020 Views 92,814 Applies to:
Answer
Answer
Thanks The geek for your help.  No thanks in any way to anyone from Microsoft.  None of this reflects well on Microsoft; not the design of current Windows 7 CM interface, not the fact that after years of complaints and messing around with Color Management they might have finally got the mechanics in place, but still can't explain it or make it possible for mortals to use it, and certainly not the fact that they create these monsters and offer no support whatsover, none.  Not one response from a MS qualified person here, not one correct answer to similar questions dotted all over the web, no after sales support service for any period after buying a new MS operating system (it's supposed to be offered by the OEM but of course none of them know this sort of thing, how can you expect them to if Microsoft don't?).  So - NO support.

I can't believe I fell for the hype and bought a new Windows system.  I swear this is my LAST windows purchase.  Microsoft, despite amazing improvements in Win7, still just don't get it.

The answer to my problem, thanks to some photographers and no thanks to Microsoft is as follows...

1. ASSOCIATE YOUR PROFILES WITH A DISPLAY AND SET AS DEFAULT

To apply an existing ICC profile (an ICM file created by some calibration process), do the following -

Control Panel / Display / Change Display Settings / Advanced Settings / Color Management / Color Management (again!)  / Devices / select one of your displays*1  / click "use my settings for this device"*2/ if necessary add the applicable profile to the "Profiles associated with this device" box using the "Add" button (if your profile is not already listed but is available somewhere on the network or computer) / click on the correct profile in that box and click "Set as Default Profile".

*1 the CM dialog boxes don't label your displays the same way as other dialog boxes, they seem to lose the manufacturer and model number info that is available elsewhere, so your ABC model nn display comes up as Display: 1. Generic PnP monitor .  Also note that at least on my system, display '1' was in fact display '2' in other display settings dialog boxes, and vice versa. 

*2 You would think that selecting "Use my settings for this device" would mean the Windows would use your settings for that device (display), but apparently it doesn't.  It means ... well, I don't know what it means.  Perhaps it means if you don't select it, even the next step (below) won't help you.

Good work so far - tortuous and unnecessarily complex - but has a certain logic.  Unfortunately it doesn't achieve anything at all, until you work out the secret key.  Although it seems the above should do what you want, you have to do something which is entirely unobvious, and not mentioned at all in any of the help general discussion, and apparently not known by any of the 67 people who read my question.  It is actually listed in the MS help section... at the very bottom of "Understanding color management settings" and after a mass of largely incomprehensible stuff which doesn't appear to be relevant, there is a link which is not listed in the contents at the top and almost impossible to notice... To enable or disable calibration loading by Windows  

2. ENABLE CALIBRATION LOADING BY WINDOWS

Here's the hidden bit of help file...

    To enable or disable calibration loading by Windows , you must be logged on with a user account that has administrative privileges.

  1. Click to open Color Management.

  2. Click the Advanced tab, and click Change system defaults .

  3. Click the Advanced tab in the Color Management - System Defaults dialog box, and do one of the following:

    • To enable Windows to load display calibrations, select the Use Windows display calibration check box.

    • To prevent Windows from loading display calibrations, clear the Use Windows display calibration check box.

  4. Click Close in the Color Management - System Defaults dialog box.

  5. Click Close in the Color Management dialog box.


Not only is it obscure, it is confused further by the fact that you are back in the same dialog box twice, but the second time it is labelled Color Management - System Defaults instead of Color Management as it was the first two times.   But only on the second time is the required box enabled to allow you to tick i.e. it's a system wide setting.  Easy to miss.

Either MS's experts don't know about this, and can't find it in the help files either, or they couldn't be bothered answering my question.  In any case a) I hope this helps someone else, and b) I hope MS lift their support game and actually respond in future to people as frustrated and helpless as I was.  Thanks Microsoft for wasting a day of my life.


170 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.