Autorun not working

Hello,

I'm using Windows 7 home premium for the past couple of days. The autorun feature worked like charm for the first one week since I got my laptop but lately it has not been working. I dont have a gpedit running in my os so please temme ways in which i can enable the lost autorun feature. I have also set the autorun enabled under control panel -> autoplay and rest of the setting as ASK ME EVERYTIME. But whenever I plug a DVD or USB the system never takes any action. And autorun is also active under regedit. Any light in this issue would be highly appreciated. Thank you.

 

Question Info


Last updated July 1, 2019 Views 12,416 Applies to:
Answer
Answer
Hi,
 
 
1. Is that an issue with all the usb devices that you use?
 
There are many reasons that can cause the 7 AutoPlay (or AutoRun) not working and does not pop up. If you’re facing the AutoPlay not appearing issue, the guide below will point you to the possible cause and where to check for the error.
 
Method 1.
Ensure that Shell Hardware Detection service is running.
AutoPlay might be restricted by Group Policy, it could be canceled by a program that is running, or the service that AutoPlay needs to start might not be running.
Here are some things to try:
Follow these steps:
a. Click the Start button, click All Programs, click Accessories, and then right-click Command Prompt.
b. Click Run as administrator.
c. At the command prompt, type net start shellhwdetection, and then press ENTER.
d. Restart your computer.
 
 
Method 2.
Let us ensure that correct NoDriveTypeAutoRun and/or NoDriveAutoRun policy value is set.
To check this setting, run Registry Editor (regedit).
 
Important: This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the windows help article below.
Back up the registry
http://windows.microsoft.com/en-us/windows7/Back-up-the-registry
 
a. Go to start and type regedit.exe.
b. Navigate to the following registry key:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
c. Locate the NoDriveTypeAutoRun registry entry on the right pane.
d. Set NoDriveTypeAutoRun to default value as set by Windows 7, which is 0×00000091 (hexadecimal) or 145 (decimal).
 
Method 3.
If you suspect any virus activity I would strongly recommend you to run the Virus Scan.
a. I would recommend you to run online Virus Scan to remove any infections, if present.
Follow the link below to run the free online scan:
http://onecare.live.com/site/en-us/default.htm
 
b.  Also run the Microsoft Malicious Removal Tool.
You should be getting this tool and its updates via Windows Updates - if needed you can download it
here.

Once the scan is over then reset  the Autoplay settings and then set it to Ask it everytime and  then check.
 
For additonal information about Autoplay refer to the articles below.
 
Important:
AutoPlay will no longer support the AutoRun functionality for non-optical removable media. In other words, AutoPlay will still work for CD/DVDs but it will no longer work for USB drives. For example, if an infected USB drive is inserted on a machine then the AutoRun task will not be displayed. 

Hope this helps.



Thanks and Regards:
Shekhar S - Microsoft Support.

Visit our Microsoft Answers Feedback Forum and let us know what you think.

If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.
Thanks and Regards,
Shekhar Sharma

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.